Using IP camera with Ignition

Here is a link that may help with finding the Video Streaming Address that you will have to use in Ignition when using IP camera’s.
Camera Video Streaming Addresses

and here is a link to the “ONVIF” discovery tool. If your camera is “ONVIF” certified then you should be able to run the discovery tool and it will display the address stream you need to use in Ignition.
ONVIF Discovery Tool

Hi dcamp,
Thank you for the above information. We are not able to open “Camera Video streaming Addresses” link, may be that page was move to somewhere else. Could you please share the link once again for us?

We are working on ONVIF (same) type of camera and we are not able to access the live videos in Ignition’s IP camera component.
Could you please suggest settings/URLs, we need to confirm? How we could find out the URL for that camera?

We are trying with this URL: “rtsp://user:password@IP address of camera:rtsp port/profile2”

Thank you in advance.

Yep, looks like it has changed. Here is the new link RTSP Addresses

Must be something wrong with the Ignition forum as I can’t get the new address to work either.

Here is the actual address

Have you search the forum? There is much topics about IP Camera viewer in Ignition…
Ignition IP Camera viewer DOESN’T support rtsp!

Has anyone gotten Point Tilt Zoom (PTZ) functionality working in Ignition with an ONVIF camera? We tried with Sepasoft Web Services but it didn’t appear our Pelco Camera provides the .wsdl from the web server (camera). No wsdl provided by the server means web service doesn’t work with Sepasoft (according to their support).

I’ve done some testing (but never used in real projects) with Foscam IP camera with PTZ and it was working OK.
Foscam uses CGI commands (CGI User guide).
Here’s my test project (v7.9.9): ipCamera1positioning_2018-11-07_0934_partial.proj (13.6 KB)
EDIT: correct project uploaded

Thank you zxclo, i tried importing your partial project and get an error below. Am i missing something from my install? I am using 7.9.9.

SerializationException: Unexpected parsing error during binary deserialization.
caused by IOExceptionWithCause: java.lang.ClassNotFoundException: com.inductiveautomation.ignition.common.model.values.QualityCode
caused by ClassNotFoundException: com.inductiveautomation.ignition.common.model.values.QualityCode

@zxcslo, your project export is from 8.0.0, that’s why it’s not working on the 7.9.9 gateway.

Ouch, sorry…
I was just playing with version 8…
I’ve corrected the upload.

1 Like