ValidationException: Unable to communicate with gateway

I’m posting this issue along with my solution, in case anyone comes across this.

I was suddenly receiving a [quote]ValidationException: Unable to communicate with gateway[/quote] error when starting my client. The confusing part is this was from my development laptop (which has always worked) and I had no problem launching my designer or getting to the server gateway :scratch: Communications was not the issue. I saw absolutely no errors / no entries in the console nor in the wrapper log file. I looked through the Java console too, but it was cryptic and not much help - it showed an error being thrown toward the end of its launch but that’s it.

Then light bulb goes on :bulb: - let’s check the local client temp files. There is a cache folder, and after I deleted that folder (with my client and designer closed) I was back to normal - my staged and published projects launched fine. It was a simple fix, once I knew what to do.

In my case the cache folder was located here: C:\Users{username}.ignition\cache.

Hopefully this helps at least one other programmer.

interesting topic. What will be affected by removing the cache folder?

Really, nothing. The .ignition folder stores local stuff for the clients to run, like Jython libraries. If you delete the folder, a new one will be created and files downloaded from the gateway, as necessary. deleting the folder and running javaws.exe -uninstall have quickly resolved some client issues.

I was having the same problem with remote clients only (gateways on different machines). I deleted the cache folder in the .ignition folder. I needed to un-check read only, then the folder was able to be deleted. I am able to start remote clients now

I experienced this error today with version 7.9.12. After lots trial and error, and some time with Aaron from technical support, we discovered that there was an issue with the gateway address in the client launcher.

If you have SSL enabled on your gateway, you need to specify both 8088 and 8043 in the gateway URL. it should look something like http://192.168.1.101:8088:8043.

2 Likes

Thanks for this, it fixed it for me just today too.

This is a bit silly and you’d think potentially this is something the native launcher could “discover” when finding or manually adding just the root address of the gateway to save the manual entry.

2 Likes