Vision - Add Gateway Host unreachable with Domain

Is it possible to use a domain name with Vision for the Vision Client Launcher? I can access our gateway in a browser perfectly fine with http or https but when adding a Gateway in the Vision Client Launcher using a domain it just says “Host unreachable”… we are using CloudFlare, maybe that’s the problem. we can only use SSL through a Domain name.

But I don’t really understand why though. I can only get it to connect using the IP address of our Gateway. Also, our Perspective Clients work fine with https.

I would like Vision to use SSL but I can’t get it to connect to the Gateway. We do have SSL/TLS Enabled.

(Snapshot from our Gateway)

Once 8.0.13 final is out, you can download and install the Vision Client Launcher from an install, and it should give you a prompt to accept the self-signed certificate entirely within the launcher.

I’m not sure that’s relevant… their screenshot shows they have a real CA-signed cert.

Hm, good point. What are you seeing when you use SSL/your domain name/both inside the client launcher?

I can get to our Gateway in browser here fine:

Doesn’t seem to give me issues. But in the Vision Client launcher I get “SSL Certificate not Found”.


What’s weird too is this actually worked briefly. I was able to login fine and then a few minutes later it’s unable to connect to the Gateway:


Well, for what it’s worth, it worked just fine on my local machine…
Anything that might be weird inside your network, like custom DNS or anything? Can you try from a machine outside your local network?

Thanks! I just tried a separate computer on the same network (I’m at home) and it worked…

So, it must be my work computer somehow. I disconnected all my VPN’s too. Figured it might be port 8443 but it must not be blocking as my internet browser can get to it?

Scratching my head on this one…

Does your work network have some kind of stupid firewall appliance that tries to MITM SSL connections?

maybe… I don’t know enough about that to know for sure. But it might make sense. We’re using CloudFlare so when you use the domain name our Gateway IP address and the Domain name IP address will be different.

So, using an Internet browser on my work computer is fine but using the Vision Launcher causes issues somehow…I’m going to ask one of our IT people as well.