Vision Client Launcher Closing on Startup

Hi guys,

My vision client launcher shows a window for a second then closes itself instantly.

The logs are:

INFO [ClientLauncher ] [2020/12/03 09:58:17]: Set initial logging level to INFO
INFO [ClientLauncher ] [2020/12/03 09:58:17]: Updating logging level to INFO
INFO [ClientLauncher ] [2020/12/03 09:58:34]: Set initial logging level to INFO
INFO [ClientLauncher ] [2020/12/03 09:58:34]: Updating logging level to INFO
INFO [ClientLauncher ] [2020/12/03 09:59:27]: Set initial logging level to INFO
INFO [ClientLauncher ] [2020/12/03 09:59:27]: Updating logging level to INFO

And so on. I have tried the latest version of Java as well as various past versions to no avail. I also have disabled firewalls/antivirus but also no luck.

Any ideas?

You’ll need to launch in a terminal to see what is going on. To do so, look in ~/.ignition/clientlauncher-data/visionclientlauncher.log for the final java command that actually runs the client. Copy and paste that into a terminal to run the bare client. Show us the errors at the end when the client dies. (Or the entire output if not too large.) Please use the pre-formatted text button (this: </> )after pasting so it will look right on the forum.

Hi pturmel,

What you’re seeing there is actually the end of the logs, there is no final java command as you say. Running the .exe from the terminal similarly yields the Vision window for about a second, then closes it. There’s no message from the terminal showing an error.

My only clue is that on install of the vision client launcher, the following error is shown:

Capture

This error message does not recur after the initial install.

Thanks for the help so far.

That would be a local IT restriction against java, I think.

I have tried just about everything in that regard. User privileges, firewalls, anti-virus, etc.

Very frustrating but I’m sure I’m missing something. I am open to further suggestions!

Heh. I recommend Linux for both clients and servers. (:

2 Likes

can you right-click > run as administrator and get it to launch? It looks like the launcher was installed for all users. you could try uninstalling it and installing it just for your user (a prompt will appear prior to install)

My quality of life would skyrocket. I’ve been trapped in the Windows world for the last 3 years and coming from well over a decade of Linux I can confidently say just about everything is worse here

It pays the bills but sometimes I wonder if it’s worth the endless frustrations

1 Like

The “if you can’t find it, grind it” of computering