Vision Easy Chart will not Poll

After spending lots of time on every video and article I can find, none of the solutions works to solve why my Vision Easy Chart set to Realtime Chart Mode with tags already set to Historize. The Tag properties for History are set properly for our Storage Provider and use all the default settings such as Sample Mode set for On Change.

The Behavior of the Easy Chart has the Poll Rate set to 1,000. In the Easy Chart Customizer, I’ve tried either and both the Tag History Pens and the Calculated Pens to the historized analog tags. With this and a few other things I’ve tried, I cannot get the Realtime Easy Chart to auto-update the values and express them on the graph.

As to what I’ve read here in the forum, it seems it’s a common problem, and had no clear and direct solution has been provided. Is anyone willing to help me please and could provide a simple step-by-step procedure to solve this reoccurring problem? Any help would greatly be appreciated. Thank you :slight_smile:

I revisited the problem, but I’m still having the problem that the Vision Easy Chart will Not update in Realtime. Even replicating the the Vision “Indirect Easy Chart” by the Inductive University, it still will Not update.

My new recent approaches is of the following:

  1. Written a script to write to a local Memory Tag (“SelectedLeg”) to hold an Integer Value that will store of which button has been pressed to open (not a new Window or Pop-up Window) the “Easy Chart” of the Analog Historized Tag.
Select_Leg = 1 #'1' is RL1
system.tag.writeBlocking(['[Tech Tag Provider]Leg/SelectedLeg'], [Select_Leg]) #Write the Button number to the Memory Tag
  1. Created a Integer “Custom Property” on the Root Container of the Window for which this “Easy Chart” will be displayed called “Select_Leg”. This is bounded to the Memory Tag (“Selected_Leg”) as mentioned above in Step #1.

  2. Created a Vision “Easy Chart” as recommended and add a single “Tag History Pen” (“Tech Tag Provider]Leg/ChartMotorLoads/MotorLoad_16”). This pen will be used Indirectly as will be shown later and be given a better path and names later on after we can get this sorted out.

  1. In the “Vision Property Editor” of the “Chart Configuration”, “Tag Pens” we’ve created a link in the “Cell Update” section of the “Property Binding”. In the “Cell Bindings” for the Indirect Bindings for “Row 0”, I have the Root Container Custom Property “Select_Leg” in place to change which analog historized tag it will change to and be displayed. On the same row, it’ll update the name of the tag that is displayed on the Easy Chart.

  1. This is the “Dataset Editor” that the “NAME” and “TAG PATH” will change from the Indirect Binding set up in the previous step.

  1. For additional Information on the Vision Property Editor of the Easy Chart:
    Behavior:
    Chart Mode: Realtime
    Poll Rate: 1,000
    Everything is is set for default.

I really need this issue to be resolved as soon as possible as I have 5 other people waiting for me to have this issue solved for them to use. Thank you for any help I’m able to receive.

You have a binding on your Tag Pens for the chart. What do the settings for that binding look like?

Property Binding to “Tag Pens” in the “Cell Update” Binding

Dataset
NAME: MotorLoad_9
TAG_PATH: [Tech Tag Provider]Leg/ChartMotorLoads/MotorLoad_9
AGGREGATION_MODE: MinMax
AXIS: Default Axis
SUBPLOT: 1
ENABLED: true
COLOR: red
DASH_PATTERN:
RENDER_STYLE: 1
LINE_WEIGHT: 1
SHAPE: 0
FILL_SHAPE: true
LABELS: false
GROUP_NAME:
DIGITAL: false
OVERRIDE_AUTOCOLOR: false
HIDDEN: false
USER_SELECTABLE: true
SORT_ORDER:
USER_REMOVABLE: true

Cell Bindings
RowColumnValue
0…TAG_PATH…[Tech Tag Provider]Leg/ChartMotorLoads/MotorLoad_{Root Container.Select_Leg}
0…NAME…MotorLoad_{Root Container.Select_Leg}

The below image is the Tag Editor of the tag that this Cell Update Binding of the Tag Pens are bounded to. Note, the “MotorLoad_9” is among 17 others that each is associated to a number assigned in the “Select_Leg” Integer Memory Tag bounded to each individual buttons to change the Value of the tag to the respective Analog tag to change one Vision Easy Chart. The “Sample Mode” is set for “On Change”, however these tags are constantly changing.

I hope this is everything you need to help understand and resolve my problem. Please don’t hesitate anyone to ask for more information that I may have missed. Thank you and appreciate to everyone’s help :slight_smile:

Hmm, I just did a quick test and its real time for me.
I created a new easy chart, drag and drop a historized tag into the chart, changed the mode from historical to realtime. I also tried leaving it in historical and using an expression binding to set the end end date to now() which worked also.

Do you mind posting snippets of them to me including your scripts please? I can’t drag a single or multiple tags onto the Easy Chart because I need to use the tags indirectly to work with buttons to change the chart to display only one pen.
Thank you

it was a basic test, no scripts, 1 expression, and a single tag. The first test the only thing that was not default was Chart Mode.

pens:
image

For the second test all i changed was the end date:

I confess that I don’t use the easy chart very much, but how many tags are you talking about? if its not a huge number could you just add all your pens, then selectively enable/disable and hide/unhide with a script? This post may help with the disable and hide approach.

I replicated yours by dragging a Historical Analog Tag onto an Easy Chart and added “now()” to the Expression and still no real time. By the way, the Chart Mode is set to “Realtime”.

Did you start with a new chart? I suspect that you have something hanging up your original chart, but that really not much of an educated guess.

Yeah…multiple times and with new tags and tag paths.

Unfortunately i am out of ideas, cannot replicate the issue.

  1. new completely stock easy chart
  2. Drag a historized tag(s) from tag browser onto the chart
  3. Set to realtime mode
    This should work, i did see a post for 7.9 where this was a bug but i don’t know when it was fixed.
    Saw another post where if you had a malformed data set polling would not work.

Sorry josborn, that was what I was referring, and I only see historical of the data on the Easy Chart and Chart even when the Chart Mode is set to Real Time. I appreciate your effort to help.

I think i may understand, and the issue may be how we are defining real time. I have my tag history set to on change, which i considered the same thing as real time.

Same :confused: