Voice Notification Dial 9 For Outside Line

Hello. I am using the Grandstream HT-813 with the Ignition Voice Notification Module (Ignition ver 7.9.14).
My issue is that the land line requires a 9 followed by a pause before dialing the rest of the number. We have been using this line successfully with another dialer without issue by adding a comma in the call string (9,1xxxxxxxxxx). Adding a comma in the Ignition user source contact phone number results in an error showing in the log “Error state received from call manager, Reason: Forbidden [403]”. With no comma, some calls do go out, but the majority fail. I have looked into adding the 9 prefix in the Dial plan in the FXO port configuration of the Grandstream, but have not been able to figure out if a pause can also be inserted there.
Any insight into options to resolve this issue would be greatly appreciated.

Hello. I am curious as to what the firmware version is on your Grandstream HT813 device is. I have been seeing reports of the HT813 only making some of the calls and I have been able to replicate this behavior with our in-house testing device.

How long have you been using the HT813 with Ignition? Did it ever work correctly and make all the calls? I am working on a theory that the the newest HT813 Firmware may have created problems.

When I test with our HT503, it works 100% of the time. As well as when we use a service like Skype for voice notifications. So Ignition is still performing as I expect it to.

In regards to “Dial 9”, I have not had to configure that, as our test line does not require it. But if some of your calls are going out “as is”, then I suspect this may be an issue with HT813 only making some calls only and not an issue with “Dial 9”.

FYI: I continued to work on this HT813 device, and I believe I found the issue with the device only making partial calls. The HT813 (in our situation) requires that the "Wait for Dial-Tone: " setting on the FXO Port Settings page be set to “Yes”.

On our HT503 device, we have this setting a “No” and it works just fine. Maybe the HT503 (an older device) is slow enough that it did not need the wait.

I did upgrade to the “beta” firmware version, but I am NOT recommending it, just stating the facts. It did not make a difference with my initial setup.

In regards to the need for a pause after the “Dial 9”, I did not come across a setting.

Don’t forget, you have to reboot the HT813 for the settings to truly take affect.

Please let me know if this helps at all.

2 Likes

dmalan,
Thank you for the tip. We have not used the HT-813 prior to this installation. The firmware is 1.0.1.2. I changed the “Wait for Dial Tone” to yes and it is definitely working better that before. I have not been able to make it fail since making the change. I will continue to watch it.
Thanks again.

1 Like

Hi,

Thanks @dmalan for the tips in this post. Running into a similar issue on Ignition v8.0.16. Same HT813 Grandstream VOIP Gateway, same firmware (1.0.1.2), Voice Notification Module version is 5.0.16 (b2020082513). We’ve adjusted the “Wait for Dial-Tone” setting to “Yes”, applied and rebooted the gateway, then attempted to test the notification. The two errors “cannot find invite client transaction for call” and “Error state received from call manager. Reason: Forbidden [403]” still occurred.

I’m curious if this is an issue with formatting of phone numbers in our user’s contact info, as I do not think this is an issue with Ignition, but the Gateway configuration. The formatting we have is xxx-xxx-xxxx, dashes included, but no country code. Any other tips you may have is greatly appreciated.

Just to be clear, you state that you made changes to the HT813, applied the settings and then restarted the gateway? By gateway, are you referring to the Grandstream Device or Ignition? Making changes to the HT813 does not typically require any restarts to the gateway(Ignition), but rather the Grandstream HT813 device needs to be restarted for the changes to take effect. (Just making sure)

In general, it seems as if the calls are more consistent when there is a country code with the number inside of Ignition. (I know the Grandstream device can be configured to insert that, but I have not set it up that way)

It sounds like your issues are more of a communication issue between Ignition and the HT813.

Have you gone through the entire guide via Support? HT813/HT503 Guide

It is important to make sure you have the Primary SIP Server on the FXO Port page setup correctly.

Also, did the HT813 ever work for you?

Hi,

Yes, by Gateway, I was referring to the Grandstream Device. This device was reported by the facilities team as working in the past, that they were receiving phone calls. However, I am not 100% certain that all calls were being received.

I have not seen that HT813/HT503 Guide, and will have to read through that and confirm the configuration settings on our HT813 are correct. If everything checks out, then I can look into experimenting with adding the country code into Ignition and seeing the results.

Thanks @dmalan, will update this thread with results today.

1 Like

Update: I was able to confirm all of the configuration settings matched according to the HT813/HT503 Guide. I modified the Answer Timeout in the VOIP Notification Profile on Ignition from 60 seconds to 120 seconds, and corrected the user’s phone number formatting according to the guide. The Voice Notifications are currently being received. Will continue to monitor over the following days. Thanks again for the response!

1 Like