Voice Notification Stops Working

Hey guys,

I have the voice notification module (newest one 1.6.1) installed and it will work fine for a while. Then all of a sudden it will stop working. It calls the number but when you pick up the phone there is dead air until you hang up the phone. After you pick up the phone the following error appears in the console:

I’m not sure what’s causing this as I’ve tried to get it to happen under set conditions and can’t replicate it consistently. If any additional logs are needed let me know and I’ll get you whatever you need. Thanks!

Actually, while looking through the log it looks like it may have something to do with the voice mail forwarding. Not sure if this is the root cause or not, I’m sure a lot of the calls go to voice mail and it seems to work ok most of the time.

VoiceErrorLog.txt (13.3 KB)

Does this cause the voice alarming to not work until you restart, or for some amount of time, or does it recover?

I can’t say for sure what’s going on from that log, but there certainly are some ugly things that could be cleaned up. The initial error, the “InterruptedExecution”, is not really a problem, that’s just due to the call lifetime expiring (we should probably add special handling to prevent that error from being logged). The rest of it, though, is interesting… especially the fact that port 8000 is apparently left open.

I’ll look into it more…


Hey Colby,

I can’t get the voice notification to work again until the gateway is restarted. So far leaving it go just results in the same behavior (phone rings but dead air after). If I try to just restart the voice notification module it comes up faulted and requires a gateway restart anyway.

Ok. Since the error concerning the port being open is for the RTP port, which carries the audio, I think something is happening that leaves it open and kills the original holder. I’ll try to take a look and see what might lead to that.

The inability to restart the module is a separate issue, I think, where the native dll in use is locked and not released.

Do those same sets of errors happen each time this problem occurs?


I think so but I will confirm. The problem is that I can’t restart the gateway during production, which is most of the time, so once I get a chance to do it and the problem happens again I’ll let you know and get you the logs.

Hey Colby, I got it to fault out again this morning. Looks like the same errors in the logs. I did notice that it seems to only happen when the phone is not answered. I ran some tests this morning and every time I picked up the phone and went through the script the next time the system would call it would work fine. If I ignored the call then there seems to be a 50/50 chance that this error will come up and it won’t work anymore after that. FYI.

VoiceErrorLog2.txt (21.3 KB)


Thanks, that should be enough for me to get somewhere. It looks like even though we’re canceling the call, due to the answer timeout, 10 seconds later the voip system is saying “Hey, it’s answered now!” (presumably for voice mail), and that’s throwing things off. I see if I can mock something up.


I think I’m getting close to narrowing this down. In my case, though, I can get it to work again by simply editing the voice profile and saving… that might help you get around it without having to restart the server until I can get it figured out exactly.

Anyhow, I suspect that I can get a module put together for you by the end of the day which should help.


The fixes will be in 7.6.2 beta 1 tomorrow, but I’ve also pm’d you a link.


Hey Colby,

I installed the new module and so far it’s been working good. All the same tests that would cause the module to fail before so far have not caused the same issue. I’ll leave it go in actual production use and monitor it, I’ll let you know if I run into any more issues. Thanks for the help!

Hey Colby,

Just wanted to follow up. The voice module has been working great for the last few days with no problems. I think you got the issue fixed with the last update. Thanks for taking care of this!

Great, thanks for the followup.