Web Browser Component Shows Blank

We are running a trial version of Web Browser module just to for testing. For some reason, I get a blank web page after I set “Starting URL” property to www.google.com. I can go to any website once I launch the client, but I need it to open a certain website once a window is opened. Eventually, we will be launching web apps (like http://10.x.x.x:8088/example).

As a workaround, I added this script in propertyChange to launch it automatically:
event.source.startingUrl = "www.google.com"
event.source.currentUrl = "www.google.com"
but now I can’t open any other website like www.yahoo.com. I tried using Web Browser component on a different gateway and I got the same behavior.

What is it that I’m missing here?

Ignition Platform Version: 7.9.7
Web Browser Module Version: 3.9.8
Java Version: 1.8.0_171

All clients and gateway are running same java version.

Had the same problem with setting the starting URL to a given location. My script looks something like this and lets me nav as needed.

if event.source.currentUrl == “about:blank”:
event.source.startingUrl = “www.google.com

Hopefully this will help you out until this is looked at.

This is fixed in 7.9.9:

1 Like

Yes I did same thing for now, but if you need to navigate to a different website, it doesn’t let you.
I’m waiting for 7.9.9 to be released. Thanks!

Interesting your isn’t allowing you to navigate to other websites. Have you tried the script i posted? Just curious. The script i posted is running and can navigate the web like a normal browser.

I’m running 7.9.8. Hope this helps.

I know this is an older post, but I’m experiencing the very same thing in 7.9.16. My work around is to look for the “about:blank” and force the page I want to go to, but even that fails at times. It seems like you have to navigate to a different page than the original you were trying to load and then it will work. I’ve also noticed that if you turn on the logger for the web Browser you get SEVERE errors showing up on the console in regards to SQLite.

That sounds like a somewhat different issue - are you in contact with support about it?

I’ve had support look at it a few times with no answer. It seems to be coming from the Web Browser.
Here’s an example. This happens when you re-open the project after being loggedout.