WebDev Self Signed Cert on Localhost

I am trying to setup my local dev environment so I can test out some WebDev calls that are setup to require HTTPS. Everytime I try making a post call to the WebDev resource I receive the message “unable to find valid certification path to requested target”

If I turn require HTTPS off and change the url to HTTP the post works as expected.

I have followed the steps in this post to install a self signed cert on my local dev computer, but that does not seem to fix it. https://forum.inductiveautomation.com/t/server-certificate-is-self-signed/42420

Here is what I figured out to get it working. After using the gateway page to setup the self signed certificate you need to import the cert into your computers Third-Party Root Certification Authorities.

  1. Go to your computers Manager Computer Certificates

  2. Go to the Certificates folder under Third-Party Root Certification Authorities

  3. import the certificate from your ignition install directory %ignitionInstallDirectory%\webserver\csr.pfx

1 Like

I am still having a problem from the Ignition designer. I receive the following error when trying to send a request to the secure web service url on my local machine through the designers script console.

Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I have tried adding the sslCert to the cacerts of the gateway in

C:\Program Files\Inductive Automation\Ignition\lib\runtime\jre-win\lib\security\cacerts

And I have also tried adding it to the cacerts of my designer runtime at

C:\Users%username%\AppData\Roaming\Inductive Automation\Designer Launcher\jre\lib\security\cacerts

I am able to successfully get to the secure web service url using chrome and postman, but not ignition designer.

This seemed to fix the problem. Import the SSL cert into the designer launcher settings.