What To Do With *tar.gz File?

I’ve found the automatic backup file and extracted all the files. Now what do I have to do in order to get a project back to an earlier version? Basically, I’ve lost a days worth of work and need to somehow restore what I’ve lost. Someone posted that the designer does an automatic backup but it’s a *.tar.gz file. When I extract it, I get 4 files. I don’t know what to do at this point. Help!

Those file comprise the actual internal database, which is hosted in the “db” folder, one up from where you found the autobackup.

So, all you need to do is shutdown Ignition, remove (or move somewhere else) the files in “contexts\main\db”, and put your newly extracted files there. Start up the gateway, and you should be good to go.


Thank you for the response. I tried moving the 4 files and I keep getting an error that when I try to move or delete the .data and .lobs files that they can’t be accessed because java.exe is running, yet when I go to task manager and look at my processes, java is not running. I don’t have the designer or ignition running so I don’t know what could be causing it to say that java is running. Any ideas?

Make sure that when you look at the process list, you have the “show processes from all users” box selected. If not, it may not show you the java process running under the “system” account, which would be the gateway.

Okay, I was able to move the files over and when I restarted the gateway and started the designer, it was not the project that I expected. I’m pretty sure that the auto backup file is time stamped for the correct file. What I’m looking to have restored is a few screens/windows that I have done quite a bit of work on and when I restore using the method you called out, the screens/windows that I would expect to see aren’t there. Any suggestions?

Well, the files of that auto backup comprise the full internal database, so it should have all of your windows, groups, internal sqltags, etc. If the contents aren’t what you’d expect, there are basically only 2 possibilities, that I can think of: The autobackup isn’t from the right time, or some other mechanism (such as clustering) is loading a different backup on startup.

I doubt it’s the second, but I would suggest going through the backups and perhaps restoring them on a new installation. The auto backups are created several minutes after clicking save- so you’re looking for something right after you saved all of your work.


Okay, thanks. I already tried doing a fresh install and restoring the files and it still didn’t work. Looks like I don’t have the correct backup.