When encountering the error "launch error occurred, downloading of launchclient.jar failed, launching will not occur" in the Ignition Designer Launcher on macOS system

How do you do?

I'm encountering the same issue. Running Ignition Edge v8.1.28 on MacOS 11.7.6. This only occurs when trying to launch a designer session on the gateway itself; when launching from another Mac pointing to this gateway, it works fine (the other Mac is admittedly running a much newer version of MacOS; the gateway is on old hardware we dusted off from the cupboard because the production hardware is still several months away from delivery).

I'm currently running in trial mode, if that's relevant. Another thing I'm not sure if is relevant, but on the gateway configuration page, Ignition Edge Panel is listed as "Available" rather than "Installed". Clicking on the Install button just redirects me to the modules page, so I'm assuming that it wants me to manually install it, but I can't see anywhere on the Ignition website where that specific module can be downloaded.

Any idea on how to troubleshoot this further? I've tried reinstalling the gateway and the designer.

Hi, Same error to me. Can anyone find a solution ?

Same Error over here.

Found a solution!!

How to Clear Client (.ignition) Cache and Java Cache – Inductive Automation Help Center


1. Clearing Client Cache

1 Like

Thanks @Jorge_Fossi, that worked for me too

That worked here as well for macOS Ventura 13.1

For TLDR people, close any clients and designers open, then open a terminal prompt and give the command:
``sudo rm -rf ~/.ignition`
Type your user password and that should be it

*sudo was necessary here due to the permissions Ignition set to the folder


Thank you!
This issue happened to me as well running 8.1.33 and linux 6.5 kernel. (I had to manually update openjdk to 19), I had to launch designer using Sudo for it to launch the project designer, but i could not close the project designer. Changed the project designer folder permissions to 755, still no luck. I did the rm -rf ~/.ignition. This has corrected my issue. Now the project designer will launch without Sudo (do error on downloading clientlauncher), the project designer works as normal and after, you are able to close the application as normal. Much appreciated.

Saying thank you as well. I had the issue where, in Debian 12, the .ignition folder was created (I think during the Gateway installation) that required being a superuser to access. Deleting that folder as described above cleared that issue and allowed the Designer to launch.