Windows blank in client after using find and replace

Has anyone else experienced windows being blank on the client after using find and replace on script text?

if i open the window that is blank in the designer and click save and publish the window will display correctly in the client again.

Thanks for the help,

Can you explain how to reproduce this?

What i did was i used find on all windows in the project and i searched for “fpmi.nav.centerWindow*”

then i replaced with the string “#removed centerWindow function”

after it finished the replace I saved and published the project. when i opened the client all the components were missing and the startup window was blank.

Hmm, I was unable to reproduce this. Can you copy the project to a test machine and see if it happens again?

yes it does the same thing on a different machine. i sent an email into support with the project files of before and after the replace.

I have also tried replicating the issue without success. What version of Ignition are you running? Also, when your components disappear can you still see them in the Project Browser hierarchy?


The components are only missing in the client not in the designer. all the windows can be seen fine along with the components in the object browser.

Here is how I can reproduce the problem.

create a project
create a main window that starts on start up
create a button on the window
on the button event action performed put the following code


print "test"

copy the button 3 times any where on the window
close and save the window in the designer
save and publish the project
press F10 to launch the client
login to the client
you will see all the buttons
leave the client open and go back to the designer
open find/replace
find “system.nav.centerWindow”
replace all with with “#system.nav.centerWindow”
save and publish the project
go back to the client
update the client if it does not auto update
now all the button are missing

let me know if it happens for you.

I have tried to reproduce this issue as well without success. Call Tech Support and reproduce this in GoTo Meeting so we can see what is going on. Without being able to recreate the problem here we cant really help.

Ok we were able to reproduce this with Jonathan’s help. It has been fixed for 7.4.4.