Writing to Micrologix Bits


I’m on Ignition 8.1.1, and I can’t write to Micrologix PLC bits

I can browse my PLC, read/write tag value, read bits, but not write bits

I’ve tried different data type, but as Boolean was recommended on other forum topic, most of my test was with it
The tag OPC path is ns=1,[TestPLC]L19:0/0" (also tried L19:0.0), but the result is always the same, I can only read the value
I can write to the full value (L19:0) without any issue

In the Designer -> Tag Browser, when checking/unchecking the tag, I have the error “Error writing to TestBit.value: Bad”

The error in the gateway logs is the following

java.lang.NullPointerException: null
at com.inductiveautomation.xopc.drivers.allenbradley.protocol.EIPProtocolAddress.findDataPosition(EIPProtocolAddress.java:282)
at com.inductiveautomation.xopc.drivers.allenbradley.transport.ABDF1Transport.updateTransaction(ABDF1Transport.java:360)
at com.inductiveautomation.xopc.drivers.allenbradley.requests.ABMicroLogixWriteRequest.sendMessage(ABMicroLogixWriteRequest.java:107)
at com.inductiveautomation.xopc.driver.api.requests.TimedRequest.sendMessage(TimedRequest.java:24)
at com.inductiveautomation.xopc.driver.api.BasicRequestCycle$PendingRequest.sendMessage(BasicRequestCycle.java:420)
at com.inductiveautomation.xopc.driver.api.BasicRequestCycle.sendRequest(BasicRequestCycle.java:233)
at com.inductiveautomation.xopc.driver.api.BasicRequestCycle.run(BasicRequestCycle.java:145)
at java.base/java.lang.Thread.run(Unknown Source)
1 Like

I recommend using N or B registry to monitor bits in a MicroLogix.
That might solve your issue.

1 Like