Wrong version of FPMI being reported by applet

I noticed that when I view the ‘About FactoryPMI’ page from a windowed application it correctly displays the version as 3.2.5 (build 2184), but when I view it from an applet, the version is displayed as 3.2.3 (build 2002).

As an aside I also noticed that the order of items in the help menu is different - I think the windowed version looks better.

Finally, the version of Java held in the System/Client/System/JavaVersion SQLTag shows ‘11.0-b15’ for Java 6 update 10 and ‘10.0-b23’ for Java 6 update 7. These numbers don’t seem very meaningful :confused:

Al

Have you tried clearing your Java Cache? Control Panel->Java->Temporary Internet Files

As far as the Java “Version”, my guess is that there are different metadata strings. This guy explains it in a blog post, which left me even more confused. Carl?

Clearing the cache didn’t make any difference.

Nathan, from the link you gave it would appear the version number being reported is the Java Hotspot version rather than the JRE. I would reckon the JRE is more familiar to users.

The Java Version string shown by the built-in ‘About’ popup is much clearer: ‘Sun Microsystems Inc. 1.6.0_10’.

Al

This is bad. Clear your browser’s cache and restart all browser windows and reload the applet and see if it comes up to date.

:scratch: Huh, well, it used to be useful. It says “1.5.0_15-b04” under Java 5 which is pretty useful, but when I run it under Java 6 it says “10.0-b22” which is totally useless. This is the value of the Java system property “java.vm.version”. I suppose that this must have changed in Java 6. It’ll be more useful in 3.3.0.