XY Chart problem "cannot read properties of undefined (reading 'dataFields')"

Hi there,

Using 8.1.11 Ignition Version

I have a view that contain a XY Chart.
There are many Input Parameters on this view and some of which are used to build a dynamic path.
To make my XY Chart dynamic, I’ve created a custom property (array) on it wich contain lists with 3 parameters (aggregate, path and alias)


The “data” of the XY Chart is bound to my key.

My problem is :

When I open the view on my session or on my designer, this error appear

I just have to refresh the view to make it works.
Something weird, when i disable the “path” binding on my custom, it works perfectly.

I tried to script a refreshBinding on View Startup part that after 1 second refresh the “path” property : not working
I tried to script a refreshBinding on a button to refresh the “path” property : not working
I tried to pass the entire “key” parameter to the view and chart’s data are bind on it : not working

Do you know what’s wrong ?
Am I missing something?

Many thanks,
Have a good day :slight_smile:

1 Like

I have a similar problem (version 8.1.5): I have a view with an XYChart, that creates a graph with some history bindings, based on the view params. Then the view is embedded in a tab container inside another view (so the path is static): if I try to switch between the two tabs a couple of times I get the same component error, and disappears if I click on the refresh button (whish refreshes the embedded view params):

Seems to be a compoenent bug?

There was a bug with this component that may be related to what you are seeing. Looks like it was corrected in 8.1.13.