1756-L71 V20.11 Connection

Very new to ignition…

I am trying to connect with an AB 1756 using Allen-Bradley ControlLogix (Legacy) driver and having zero luck.

The IO config is:
[0] 1756-L71
[1] 1756-DNB Devicenet scanner
[2] 1756-ENBT/A - IP is 172.16.198.89
[3]1756-M16SE
[4] - [12] are various analog and digital cards.

The path in the project is - VMW\172.16.198.89\Backplane\0

Now the “VMW” is setup in Rslinx classic gateway as a server IP/Host with an IP of 172.16.198.227

I have tried using the 172.16.198.227 as the host and then the 172.16.198.89 as the local address and no go. i have also used various combinations of 1,0,172.16.198.89,1,0 and such, but nothing seems to work.

Oddly, for me, I have another Allen-Bradley CompactLogix (Legacy)driver running and connected to another machine that also goes though the 172.16.198.227 gateway and all I had to do to connect to that PLC is use the IP address of the 1768 ENBT/A card as the host name (172.16.198.161) and all was good.

Overall, I can connect to a Siemens S7-317, an SLC04 and a 1768-L43 Logix.

Omit the RSLinx. It is in the same subnet as the target ENBT, so there’s no point in hitting it. If you can’t get through, check that port 44818 is open from Ignition to the ENBT.

Thank you for your reply.

Right now using the AB ControlLogix (Legacy) I have the hostname 172.16.198.89
Local address = blank
Timeout = 2000
Slot Number = 0
Connection Path = blank (default)
Concurrent requests = 2

it just keeps telling me “connecting”

On this driver I do not have a Port setting. On another driver that I am also having trouble with I have an AB logix driver and that has the 44818 port. On that device it shows in the device connections that it is connected, BUT when I go to OPC Quick Client I cannot pull up and tags.

Time to look at wireshark. You might want support to look over your shoulder. I’m going to guess there’s a firewall issue.

Ok, I will probably have our IT guys take a crack at tracing it down. Thanks again!

Also try the non legacy driver. Isn’t fw 20 where it switches over?

Hmmm. Wouldn’t hurt to check. I thought it was a later firmware than 20.11, though.

20.17 rings a bell,

20.11 is the last one I remember being compatible with the legacy ControlLogix driver.

The 1756-L71 is using revision 20.11.

I can connect to it just fine using Rslinx classic gateway.

I tried a non-legacy driver and no go. Just reconnect wait- reconnecting reconnect wait…
I tried the legacy driver and all I get is disconnected-connecting-disconnected…

Similar issue with another machine. I can connect to Ignition using a AB compactlogix legacy driver to path:Welding\172.16.198.161 ← PLC uses revision 17.3. N-Tron 516tx un-managed switch and it connects.

But I cannot connect to path:Welding\172.198.108 using AB Logix driver with revision 31.011.

Could be the switch on that? AB Straxtix 2000.

I’m thinking that it’s because you’re running through an RSLinx Gateway connection. @pturmel , do you know if there’s a connection path through Gateway? I’ve never seen anything on it personally, but that doesn’t mean it doesn’t exist.

Which means there would be another IP adress you’re not yet seeing.

@JordanCClark could be.However, I can connect to other PLCs

Green arrow, I can connect. In red, I cannot. using Igntion. Going online from RSlinx i can all day long.

I don’t believe Ignition ever goes through RSLinx as a simple router. Some people connect to it as an OPC server.

It doesn’t matter whether RSLinx can connect (all day long or not). The RSLinx instance is in the same subnet as the target. I haven’t seen the IP address information for the Ignition Gateway itself. The path from there is what matters.

@Jim_Perks: Please share the IP address information from the upper right of the Gateway’s status overview page.

Here are some screen shots.



So, Ignition is not in the same subnet as the ENBT. So the traffic must go through a router. That router is known to pass traffic to the CompactLogix, so it probably can pass traffic to the ENBT. You need your IT group to set that up. A wireshark capture would be definitive.

The exception from your log has no bearing on this driver–it is a Perspective error of some kind.

Also, your RSLinx screenshot points to problems with 172.16.198.108, but you claim above to be trying to reach 172.16.198.89. Please expand that latter in RSLinx so we can see the backplane.

Any unrecognized device, if a Rockwell product, can have its EDS uploaded and registered so it shows up correctly.

Ok, sorry forgot to upload. Yes, I am trying to connect to .89 and .108.

Can you ping the IP addresses you are trying to connect to from the Gateway directly?

@bschroeder that is what I just heard from our It manager. He is going to dive into this shortly.

Yeah this smells like a routing issue between the gateway and the end device.