AB Logix Firmware 32 tag qualities Unknown

Ignition 7.9.10
Logix Driver 3.9.10

I’m using the above and connecting to a Control Logix (GuardLogix actually) 5583ES with firmware 32. Connection is established and I can browse the PLC, but any tag I try to read has Unknown quality.

I’ve just tested now in Ignition 8.0.1 with Logix Driver 4.0.1 and this works, so I’m guessing there was something added into this version to handle changes in the later AB firmware versions. I note that this version isn’t compatible with v7.9.10 so I can’t just install it into my existing gateway. I’ve created a support ticket as well, but are there plans for this functionality to be added into a driver that’s compatible with 7.9.10? I don’t want to upgrade this customer just yet while v8 is so new.

1 Like

There’s only 1 commit in the Logix driver shipped with 8.0.1 that isn’t in 7.9.10 and it’s waiting to be released in 7.9.11.

AFAIK it’s not directly addressing this issue though. I’m not sure what you’re seeing or why you wouldn’t see it in 8.0.1 also.

I just tried this in another 7.9.10 install and it’s talking properly to the PLC, so I’m not sure what’s going on with the other server… How would I diagnose the issue?
Edit: server is running Windows Server 2012 R2

Nevermind, it came good after a gateway restart :slight_smile:

1 Like

I’m running into the same issue with a 5581ES running 32.11 firmware.
I’ve tried connecting to the PLC with servers running the following Ignition versions:
• 7.9.9
• 7.9.12
• 8.0.9
And I get the same symptoms as OP. I am connected, can browse, but have bad quality on any tag.

I am connected over an ENBT card in slot 2 of the rack, and then to slot 0.

Gateway restarts, and enable/disable of device connections have not helped.

For comparison, I am able to connect to an L71S and a compact logix (1769-L36ERMS) safety PLCs running v32 firmware with the same servers…

I’m having this issue again onsite, however it’s only affecting any new tags that I add for the PLC.

I have many tags from the same PLC configured that are still working, however I modified a UDT that affected some of these, and these are no longer reading in values, they are simply showing as Unknown quality. I’ve tried to read these same tags in the gateway OPC client, and they read as Good?

Any ideas? Performing a gateway restart is not an option

I have had success by opening the PLC device properties and saving it without making any changes.

Call support and they can help you turn some loggers on to troubleshoot this. Make sure you are using the Logix Driver and not one of the legacy ControlLogix or CompactLogix drivers.

This sounds like a different issue, maybe something in the tag system rather than at the driver level, seeing as reading the tags in the OPC quick client works.

Same here. It seems that downloading to a L81E with UDT updates causes this. I’ve also seen this on L72s as well… V30 and V32.

It’s not reliably reproducible on our development systems, however it does happen frequently.

Consider going online with that processor and creating a dummy tag of a standard datatype on the run. That should bump the change monitor in the processor that Ignition’s driver is monitoring.

1 Like

Did you just try a restarting the tag from the Ignition tag folder via right-click menu? (Might only v8.0 option) You could also re-start the OPC module instead of the entire gateway.

I was able to correct this issue by changing the device connection property for CIP Connection Size to defaults (500).
I routinely open Max Concurrent Requests up to 8 and CIP Conn size to 2000 to allow higher data throughput on some of my systems where I am capturing string data from barcode scanners that goes to ERP systems at fairly high rate, and have never had any issues with any AB processor/firmware combo except these L8*ES’s.

If I change the value of CIP conn size, then I lose tag quality on multiple servers, multiple versions (7.9.9, 7.9.12, 8.0.9 tested).
Default device connection settings:
image image

Modified settings:
image image

I can modify Max Concurrent Requests with no effect on tag quality. I also have 557xS processors running the same firmware as these L8xES processors that I can modify the CIP size without issues.

The default is 500 because that is what all old firmware supports. Newest firmware supports up to 4000, but it must be supported by every device along the CIP chain, including EN*T cards. You might want to check your EN2T’s firmware.

Anyways, the driver might be failing to fall back if an intermediate device is rejecting the forward open due to size. With new firmware, there’s never any value in using a size greater than 500 but less than 4000.

2 Likes

Yep, that was it - I hadn’t thought to check those links in the chain. Turns out that the L7S processors I tested against were all being reached through an EN2T with v10 or higher firmware, while the L8 was behind an ENBT. Thanks for the good info!

1 Like