Alarm journal not displaying correct alarm information for label

I have an alarm journal that worked perfect when I had one gateway and one connection to a local mariadb database. Now I have broken up the front and backend gateways so the backend has the connection to the plc and also has the tag historian module. The frontend has perspective, reporting, and has a DB connection.

The DB is now Oracle.

My alarm journal worked perfect before and I haven’t changed anything except for using the Oracle DB instead of the MariaDB connection.

My current alarms are showing up fine, but my alarm journal is not displaying the label correctly anymore. I see the alarms but the label is not showing up correctly. This is what I see…
image

Oof, interesting. What’s the Oracle DB version, and what’s the version of the JDBC driver .jar file? (on disk, don’t trust the gateway web page)

The database itself is located remotely so not sure which version it is. I am accessing the oracle DB using Oracle sql developer version 21.2.1.204. Not sure if there is a way to get the oracle DB version from the developer or not.

Quick way to see the version of the JDBC driver .jar file?

The .jar file I remember uploading was called ojdbc8.jar

SELECT * FROM v$version;, apparently.

Okay, that’s something at least. We’ll probably have to investigate ‘in-house’. Is the strvalue column of the alarm_event_data table actually an NCLOB type? That’s probably wrong; you might be able to change the column definition to a more ‘plain’ type (VARCHAR, etc) and get the right results in your journal table.