Are my settings right for email notification via pipeline?

Hi guys,

I’ve been trying to sort out getting an email sent through ignition for the longest time. I’ve followed and looked online for any possible settings i could be missing but nothing works.

I have a pipeline configured like the tutorial videos,

I have the alarming notification as follows:

For this I’ve created a new gmail account as I’ve read that gmail doesn’t like this sort of configuration so they could report/ delete the account if ever.

I’ve got the alarm tags configured:

Trying to test the pipeline/ notification profile, nothing happens i.e. I dont receive an email. I am able to ping from my host and the VM that im using.

What am I missing?
Thank you guys!

Are there any errors in the logs? Is “” actually an email address you have credentials for?

Hi kevin,
thank you for advising on this topic!

Where can I see the log specific for this function? There doesnt seem to be an error showing on my localhost
yes the [] is an account I created with a password I have set up and is the same password provided in the email settings.

In terms of the “admins” roster. I’ve got my own personal gmail and this [] as emails to users aswell

In the Status > Logs area of the Ignition gateway.

I’m not sure your pipeline makes any sense either… why would you loop continuing to send emails with a 3 second delay?

Hi Kevin,

There doesnt seem to be any errors/ anything that indicates an error of the email notification.

Apologies, this notification pipeline is the one I followed on inductive university, I’m still only going through the videos of the online course! what do you suggest?

More on the topic: on the [] I do have the setting to allow third party apps with “Access for less secure apps has been turned on” hmm

While you’re testing a simple pipeline with just the notification block is easiest.

Also using the “Test Pipelines” action in the Alarming > Notification section instead of a real alarm event.

You can set the log level for “alarm.Notification.EmailNotificationProfile” to DEBUG and enable the debug logging in the advanced settings on the email notification profile you configured. The debug logging from the advanced setting only shows up in the wrapper.log files in the logs directory where Ignition is installed.

Hm I have been only testing with the “Test pipeline” on the gateway.

Changed up the logging level as you sugegsted but the logs I have been getting have stayed the same…

I still have yet to receive an email…hmm.
Any other setting i need to change?
This is what I have configured on the notification block of the pipeline:

Take your notification block out of test mode…

1 Like

Interesting…why would I have to take it out of test mode for when I want to use the test pipeline?

Thanks kevin, I’m getting some errors now so thats one step forward! haha.
following errors:

Then I received:

However I am able to ping
But now also have an “error” in my alarm notification profile


Click the “+” next to the “error establishing connection to mail server” message (and others), there might be more info that helps.

Hi kevin, this is what shows. hope this helps.

Hi @trishadx, here’s a screenshot of a system that has notifications working with gmail.

You can try to update your notification or SMTP profile settings to match this and give it another try.

Whoa it worked!! thank you so much.I’ve honestly been racking my brain for a month over this. I’ve tried everyone else’s advice on the other forums/ topics. but i havent gotten across one that suggested to create a SMTP profile under Network> Email settings. it hasnt been mentioned. thank you so much!!
Where can i find more info/ explanation on this? for future reference

thank you aswell @Kevin.Herron for teaching me and being so patient!

Awesome guys!

Sorry guys, one more thing… similar topic. If I was to use outlook as the server, by changing the settings to the below: it gives me “authorisation unsuccesful” in my logs…is this because outlook doesnt allow third party apps or am I just missing config changes to my outlook account?

Thank you guys. hope you’re all keeping well

I’m not sure about and I don’t see those settings you posted on Microsofts website. Do you have an Office365 account by chance? If so I’d use there SMTP server.

Snippet from ms:

Oh cool thank you! I’ve changed it and im able to ping this smtp aswell.

I still get the authentication unsucessful for this outlook.
is it a similar issue where I have to change my google account to allow third party apps? I cant seem to find this option for outlook/office365. what would you suggest?

Thank you for the help btw!!

I presume youve entered in your office365 credentials into the SMTP settings? The username likely needs to be fully qualified e.g.

Also to @nminchin’s point; office365’s SMTP doesn’t support any type of spoofing. Your From Address must match the account you’re authenticating with.

Hmm I’m sure its the correct username and password as i’ve just used them to log in.

@code_skin what is spoofing in this manner…an email thats not Atm im trying to use my company’s domain @***.com which uses outlook/office 365

What I’m saying is if you have a 365 account that uses your companies domain make sure the authentication and from address match.

If is used in your SMTP profile for authentication then MUST be the From Address.

You can’t authenticate with and then use as the From Address for example.