[BUG-12519] Scripting character / cursor position

Not sure if this is happening for a lot of folks.

The character cursor on the scripting tab for all components doesn’t correctly line up with its actual position. Its impossible to deal with. Its sometimes up to 2 characters off, so you cant pick or type where you want to.

The scripting console is unaffected.

Windows 10

Thanks, we’re tracking this internally already, this post will get updated when it’s fixed.

Thanks Kevin. It makes me want to “pour tea on computer”


It’s Windows only. If you have a VM with Ubuntu or something installed you can test from there.

1 Like

If you have an ISO with Ubuntu you can wipe your Windows 10 install… :stuck_out_tongue_closed_eyes:


I’ve been writing in notepad++ and copy/pasta into the scripting tab.
However, if I owned the machine, I would implement Phil’s ‘fix’ :grin:


We’re working on a fix for this. As a short-term workaround, you can delete the fontconfig.properties file, located in your .ignition cache:
(might be runtimes\11.0.1, 11.0.2 is going to be in new nightlies going forward.

1 Like

Worked for me.
-No more odd spacing with ‘y’ and ‘s’ (unsure how other chars were effected).
-All the text is in a grid, so I know where my cursor is in relation to text above and below my cursor.
-Can tell the difference between single and double quotes easily.

I haven’t seen anything break after applying this fix. Will keep you posted.

1 Like

This should be fixed in the latest nightly deployment of 8.0. You will need remove .ignition/cache/resources/runtimes to force the changes made to the JRE to be downloaded.


I’ve been having this same issue. I have tried downloading the latest nightly build of 8.0.2 and clearing the cache on my designer machine as suggested above. My gateway is running on Windows Server 2016. My designer is running on Windows 10.

The cursor position in the scripting window get worse the longer the line of code becomes.

Any suggestions?

Try and delete C:\Users*username*.ignition\cache\resources\runtimes\11.0.2\conf\fonts\fontconfig.properties

The restart the designer

I’ve been having this same issue in 8.0.7 version.

I tried delete: C:\Usersusername.ignition\cache\resources\runtimes\11.0.2\conf\fonts\fontconfig.properties

And it doesnt worked. Then i tried delete the folder:

I and also doesnt worked.
Any suggestions?

I am also seeing this problem in 8.08

Tried deleting the fontconfig.properties file with no luck. Then tried deleting the whole .ignition folder, again with no luck.

We’re refactoring the script editors (possibly as soon as 8.0.12) in the designer so that this problem doesn’t occur anymore. Technically, expression editors (at least for now) could still be affected, but very long expressions are a lot less common than very long scripts.


What is the station of the release train for the new script editor ?

Currently, waiting on the upstream library to fix a few issues before it can go into production. At least a few more releases, at this point, given the scale of what QA needs to regression test once it’s all implemented.

1 Like

I’m having this issue after upgrading to a 4k display, I did not notice it when I was using 1080p. I’m using the latest 8.1.2 stable. My cursor is about two character lengths to the left when editing scripts. I tried deleting runtimes as well as the font file, no change.

1 Like

Just an update, I was able to change windows scaling feature from 150% to 100% and this issue went away, however now my ignition windows are very small and hard to read. I can zoom on the script editor but not the other windows.