[BUG-12764]Perspective HTTP forwarding to HTTPS when SSL enabled

It looks like there’s a bug in Ignition 8.0 regarding the HTTPS

If I understand correctly, enabling SSL should cause Ignition start redirecting all http requests to the https versions and not allowing http requests anymore.

It doesn’t seem to be doing this in yesterday’s daily build.

Are you referring to the gateway SSL setting? Enabling the setting is properly redirecting gateway pages to HTTPS for me on the latest internal build.

Which OS and browser are you using?

I believe so. I will download the latest daily and test.

Sorry, I think I missed a key detail. We’re not getting redirects on the Perspective client.

I have checked “Use SSL” under the “Config/System/Gateway Settings”

While the config pages do seem to redirect to the HTTPS version, pages served by the perspective module are still accessible via http or https (no re-direct is happening for perspective)

Ok, I loaded the latest daily. Config webpage redirects. Perspective clients do not.

1 Like

There is an issue here, but I want to confirm the issue I am seeing is the issue you see. When attempting to load a Perspective page when SSL is forced, do you see:

  1. The project
  2. An error message like the following:

If you are seeing the project, can you let me know what OS your Gateway is running on and the Browser you are loading the project in?


I was seeing that error but am not currently seeing it. I’m not sure if our IT guy opened something up or if my restoring a project backup to the server is what made it go away but I got my screens to load.

Server OS is Windows Server 2012 R2
Browser is Firefox 65.0.1 which is what launches when I select “launch session” from designer.

Currently I’m seeing a sign in window and when I hit the button “continue to sign in” it throws HTTP Error 500. I think that’s user error on my part. I’m still learning the login stuff in perspective so I might have it half way configured.

HTTP Error 500 says “java.lang.NullPointerException”

The 500 error is a known issue with the Sign In window that we are aware of. It happens when the Perspective Project doesn’t have an Identity provider defined. This can be set in the Designer via Project Properties > (Perspective) General.

As for the error no longer occurring, I am guessing that the restore of your gateway reset the Gateway setting that forced SSL/TLS usage and it is no longer required.


I was just about to post that I fixed the sign in issue. I found an old post that explained how to set up the perspective security. Anyway, the logins are working for me now and the client is loading up in firefox. The problem was what you are describing.

You’re right about the gateway backup restore. Oops :slight_smile:

Thanks for your help.

This issue was fixed in the build that was uploaded today (2/28). Please let us know if you continue to see this behavior after upgrading.