Can't import all my OPC tags


I’m having problems importing all my OPC tags in ignition… When I want to import them it doesn’t show all the tags that I have in the PLC. It shows a random selection of the tags that I have. is there some setting or so that I need to change?

Check if browsing is turned on for the PLC. I usually keep mine turned off.


use system.device.refreshBrowse('deviceName') to force a rebrowse.

Either way, you’ll have to refresh the view in the OPC Browser

Thanks for replying. When I make other tags in the PLC they show up nicely in ignition to be imported but like I said not all tags that I have in my PLC get shown so is that a browsing issue?

Check the “External Access” settings for the tags and/or UDT members (in the PLC). If “none” they won’t show up in any OPC driver.

My external access is read/write for all the tags in this folder…

What tags are missing?

1 Like

Yeah, what’s missing? The OPC driver is listing in alphanumeric order, where the PLC is in native order.

I do agree that this is annoying, by the way.

I marked the tags that are missing in the screenshots. So all these tags are in the folder CIP1. and i dragged that folder in my tag window in ignition. only the tags you see now are the ones ignition sees. it doesn’t see the tags that it did not copy either.

Well since I can’t see what hasn’t been scrolled to in the Tag Browser I can’t visually verify, and even then it’s probably not that helpful.

Why don’t you just give support a call and let them take a look.

Can you show the “read/write” column in the screenshot of the tags? If you right-click on the blank column header, you will see an item that dropdown that says “Toggle Column” and you can select 'External Access". Verify that all of the tags in that structure are read/write.

Is this what you’re talking about?

That’s it. Looks like the whole structure is read/write then. You can verify that each parameter is also read-write by right-clicking on that blank column header to the right of “Constant” and make sure all internal paramters of data type CIP are read/write.


They’re all read/write… that’s why i don’t understand why it does see some tags and doesn’t see others…

Seems like something is not working with the OPC browser.
Are you using a link to RSLinx Classic Gateway OPC or using Ignition’s built in OPC server? Also, are you running the gateway locally or on a separate server/PC?

Sorry, I missed your same comment above.

I’m using ignitions built in OPC server and I’m using a compact logix PLC. and studio 5000 logix designer version 24.00
and i’m just using it locally at the office testing right now…

You may have tried this already, but disable/save/enable the Ignition OPC server from the gateway webpage to get it to reset. That has sometimes worked for me in the past.

You mean this right here right?

No, I think he meant this, under Configuration => Modules: