Change default zoomLevel of report viewer on start

I want the zoomLevel of the report viewer to start at 50, instead of 1/"Fit to Page". I've attempted to do this by binding the value to a memory tag, using an onStartUp script to write to the property (on both the report viewer and the container), and simply typing in the value into the property. However, when I open the report for the first time, it defaults to "Fit to Panel".

I want to open the report for the first time and see the zoomLevel at 50. Is this possible?

I've looked at this page, but it isn't helpful to me: [Feature-8604] Report Viewer Zoom Factor

Simply setting the zoomLevel property to 50 works for me. Are you sure you don't have any bindings or scripts or anything else that might be conflicting?

Yeah no scripts or bindings or anything, except for the ones I added (and then removed) that attempt to set it to 50. Before the report loads in, zoomLevel is already set to FitPanel.

I just launch it using Tools -> Launch Perspective -> Launch session.

Maybe a bug on my end?

What version are you using?


Apologies for the late response.

I would highly recommend upgrading. Besides not being able to replicate this issue on the latest version, there are a whole host of other improvements. 8.0 is also officially no longer supported.