ClassNotFoundException launching Designer

I uninstalled the 7.9 version and did a fresh install of V8. I get following error on launching the designer

2 Likes

Can you enable the Java console, launch again, and then provide the console logs?

Also, check in ./ignition/ for a launch-error file.

On enabling java console from java control panel, and launching the designer, I don’t see any output on any java console! Where do I see the java console? Its windows 10 64 bit machine.


I still get the launch error:

There is no such file generated in the ./Ignition folder!

Can you try launching the executable via a command prompt and let us know if an error appears? If installed in the default location, the command to run would be (quotes are required):

“%APPDATA%\Inductive Automation\Designer Launcher\designerlauncher.exe”

Hey @Pramanj,

Im hoping to narrow this down, could you answer a few questions for me?

  1. Are you launching from the new Designer or Vision Client Launchers? JNLP?
  2. Does the Launcher itself open and this appears when attempting to launch a project?
  3. If so, if you set the Launchers Logging level to Debug you should see the launch params in ~/./ignition/clientlauncher-data/designerlauncher.log. Id like to check those out if possible

Thanks,
Jonathan C

1 Like

I am saving the “designer launcher for windows” from home page of Ignition

yes it does try first then it gives the error mentioned even before designer is opened, and before any project can be opened.

I don’t know where to set this Logging level!?

I did enter the command thru a DOS prompt but , the same thing happens and there is no message on the DOS prompt after the above error.

I have installed the latest build of Ignition 8. (Just reinstalled over the previously installed build of version 8 , hope its OK).

When I try to uninstall the Ignition, first of all it shows an old date of installation, 16-11-2018 when I first installed version 8, even if I install the new build yesterday or today. I thought it should show the new install date.

secondly when I try to uninstall it manually, it gives following error:

Could this be the cause of the ClassNotFoundException ? I was able to launch the designer first time when I installed version 8.

@Pramanj No, this is an issue that has been resolved and they are two separate issues. I would really like to see the designerlauncher.log file after setting the launchers logging level to debug. To do this could you do the following:

  1. Open the Designer Launcher
  2. Click “Settings” in the top right corner and set the logging level to DEBUG and click “Save Changes”
  3. Launch your Designer from within the Launcher
  4. Upload the tail end of the %USER_HOME%/.ignition/clientlauncher-data/designerlauncher.log file. I would like to see all the lines that contain “Launch arg” through “Starting Java with the following parameters:”. Should be about the last 20 lines or so.

That should help us get to the bottom of it.

Thanks,
Jonathan C

The designer launcher itself is not launching, it give the ClassNotFoundException Error. How can I got to the next step …

@Pramanj It sounds like some wires are getting crossed here. The Launcher has to be opening as a previous screen shot you uploaded shows a Resource Lock getting acquired, but lets take a few steps back here.

Do you see this screen ever?

This is the Designer Launcher. It allows you to save, configure, and launch Designers for multiple gateways. It is its own standalone Application that replaces JNLP launching due to the removed support in later java versions and is similar to the old Native Client Launcher.

1 Like

No, when I launch the designer by downloading and installing it from the Ignition home page, I get the following screen first , followed by the window showing resource lock etc, shown in my previous msg,

The My Designer and the launch drop down selector doesnt show for me. Although, it was coming first , but since I reinstalled new build(s) , its not coming!

Ok it looks like that particular gateway was set to be the Default application in settings. Could you try something for me? Open the Designer launcher and when you see the auto-launching screen select Cancel on the bottom. You will then see a screen similar to the one that I posted. Click on the manage button on the thee-dots button to the right of the name of the Ignition-LAPTOP-RLSQD170 Designer: image
Delete the application. After doing this, re-add it by click the blue “Add Designer” button and attempt to launch again.

Thanks,
Jonathan C

Yesss…! Thanks a lot Jonathan! I am able to launch the new designer 8 now! At last !

I appreciate your sincere efforts to resolve the issue.

Best Regards

2 Likes

Could you please share the screen shot again?

I updated the post with a new screen shot @schen

Dears
I already Installed Ignition 8 ,and have the same error.
and i cant see the auto-launching screen .
could you please help me about that?
?

Like @jcoffman said, this seems to happen when you have a particular Gateway set to be the Default application in settings.
The way I resolved this one is by opening my user folder in Windows (“C:\Users<yourUsername>”) and delete the .ignition folder (you may need to enable Hidden items from the View tab in File Explorer in order to see it). Designer Launcher should launch correctly after this, and should re-download the appropriate files when you re-add the gateway to your list.

Has to do with the designer-launcher.json file within .ignition/clientlauncher-data not having the main class defined.

You can either -

  1. Delete designer-launcher.json so that it’s recreated upon startup of the designer launcher.
  2. Within "applications" in designer-launcher.json, replace "main.class": null with
    "main.class": "com.inductiveautomation.ignition.designer.DesignerStartupHook".
4 Likes