Connecting to Allen Bradley simulated plc

I have an existing gateway project. I also have a few allen bradley plc’s that I will be connecting to but cannot connect to them currently. In order to run the plc program I have used Studio5000 Emulator which does not have an IP address associated to the plc. Is it possible to still connect somehow to this emulated plc?

As far as I know you have to use RSLinx or FactoryTalk OPC server then make an OPC connection from Ignition.

1 Like

Yes, there are a few assumptions though:

  1. OS must be Windows 10, Windows 7 will not work for whatever reason.
  2. It has to be a relatively new version, I have tested with v32 and it works.
  3. Use the IP address hosting Emulate.
  4. All other settings remain the same, unless the slot is different.

Edit, I have tested across VM Images and it works as well. Again, you use the IP hosting Emulate.


I am going across two different VM’s. When you say the IP hosting Emulate what do you mean? In Ignition I see you have to create a new OPC-DA COM Connection. In this case I would check Remote to connect to a remote OPC server over DCOM. I would enter the remote VM IP address. I’m assuming I would have to create a new topic with RSLinx, give it a name, and then make sure the ‘progid’ within Ignition matches that OPC topic name I created? Do I have to change any DCOM settings within either VM?

In Ignition, if using later versions of Emulate, you don’t need to do anything different. Use the same Logix driver (enter an IP and slot #). Run a CMD and ipconfig on the image/host running Emulate. This is the IP address you will enter into Ignition. That’s it.

If you have later versions, Windows 10, etc., it will just work. I haven’t spent time figuring out why… honestly I really didn’t care. I was just glad it did.

Edit, another post discussing this as well.

At first it didn’t work for me, as I was using Windows 7. One of the post links a walkthrough.


I have setup a Windows 10 VM with Studio 5000 Version 28, and installed Studio 5000 Logix Emulate Version 32. I read somewhere else that Studio 5000 Emulate isn’t compatible with Windows 10 after installing it. Install went fine however it literally takes 5 minutes to open, then minutes to add a module, etc. Can you tell me which versions you used to get this to work?

30 & 32, it was in the link above,

Oh right, thanks. You were able to get this working using FactoryTalk Linx Gateway or you didn’t need to use this? Just wondering high level how you got it to work

All I do is fire up emulate, download the program. I then set Ignition logix driver to this slot number and the IP that emulate is running. It’s that simple. If it doesn’t work, not sure. I’m an integrator, so I do have Linx installed, but I do/did nothing with it.

1 Like

Wow, it worked! I have Studio 5000 Version 28 program running using Studio 5000 Emulator Version 32. I have two VM"s, one with Ignition and the second one with the AB software. Once I got the emulator and plc program running I got the IP of the VM running the AB software. Then I simply created a new OPC-UA Server device, with the IP of the AB VM and the node set to the emulator plc node.
Thanks for your help! Glad I did not have to jump through a bunch of hoops to get this working


I’m having a problem. My connection remains “Reconnecting”. I think I have everything configured correctly. I tried with a v21 in slot 7 and v33 in slot 2, same result for both

ig_rw_emulate_vm_2021-06-09 at 8.33.18 PM

1 Like

I am facing this same issue. Could you please help me out if it has been resolved already ?

I gave up on trying OPC UA > Device Connections and tried OPC Client > OPC Connections. I found that with ProgID “RSLinx OPC Server” I got it working and it seems to maintain Connected status. This connects to all devices in the Linx config, instead of creating a specific connection to a device. It doesn’t seem like the optimal way to do it, but it works better than OPC UA > Device Connections. I think the issue is that Linx is not UA.

1 Like

I got the same, however when I'm trying to link a tag in the designer it says that is not connected and won't write to the tag in PLC. Does anybody know the solution for this issue?

Create an Emulate program and get that running. Once this is completed you can create an OPC topic configuration within RSLinx and point it to the desired emulator. Be sure to select apply so the topic points to the right processor.

Create a new OPC-DA COM connection on the gateway.

Select Local on the next screen and then Select RSLinx Local OPC Server on the following screen

This is what has worked for me using VS 8.1.27