Connecting to Click PLC for tags?

I have a Click PLC with a Modbus TCP connection with the following MODBUS addresses
image

This goes from DF1 to DF100, where the MODBUSS address increments by 2 the entire way.

I tried to make them like this but am getting an error that my modbus value is too high

What am I doing wrong?

Using 8.1.7

Try removing the 4- prefix from your address. 1, 2, 3, and 4 are used as prefixes in some Modbus address notations to indicate the data area to read from. 4 is Holding Register.

edit: misspoke, it’s actually 0, 1, 3, and 4 for Coils, Discrete Inputs, Input Registers, Holding Registers. 2 is not used.

1 Like

So I have a new error (progress!). That worked in that it created 100 tags, but none of them are showing the values I expected, so I must have something in my configuration off. Is there a way to delete the addresses I just added so I can try again? Or do I need to delete the device and recreate the connection to try again?

You may now have an off-by-one error. Ignition address notation starts from 1, which is 0 on the wire. Some notations actually start at 0. Try toggling the One/Zero-based address setting. If that doesn’t work try it in combination with the Word Order setting.

1 Like

@Kevin.Herron ya did it again. It was the Zero-based addressing option I tried first and that worked for me.