Connection Failures and system too slow

Hello forum,

I'm having some different issues with my SCADA system.

All the clients are running too slow. The system does not respond appropriately when we try to navigate, select, or change something on any screen. Also, everything changes to red every minute, and it returns to normal.

To do any change on my designer, the system it's too slow, and I can see every minute a little pop-up message saying "Connection Lost" and at the same time another one "Connection Restored." All day the system it's doing that.

I increased my memory to initmemory=2048 maxmemory=8192

The limit of concurrent connections between the client and the gateway. "Connection Concurrency" option in Project Properties->Vision->Timing: IT'S DISABLED.

Any advice? I'll appreciate it.

Note: Project Ignition 7.9.16 was created years ago. I just started with this company, and they have a lot of old screens not in use (on red). I'm thinking of cleaning all
the SCADA and starting over.

Thank you so much forum! :smiley:

A few obvious things you can start with:

  • What is the performance of your gateway look like? How much memory/CPU is being used? Did you restart the gateway after you allocated the additional memory?
  • What do your clients looks like in terms of hardware? Are they running low on memory/processing power?

From my little Vision experience, it seems like a slow Vision app usually means the client lacks key hardware resources and the fact that it disconnects/connects to the gateway might be a gateway resource issue. At least those are the two most obvious, glaring things to check.

So many possibilities. Share more about your gateway. Performance page from the status section. How many tags does your system have? How many are OPC tags? How fast are they polling? How is your database set up? Shared server? Virtual servers?

What shows in your wrapper log file? "Clock drift" warnings? Maybe you need java GC logging to look for pathological memory problems?

{ ps: initial and max memory should be the same on production systems. Java never gives memory back to the OS, so it should claim it all up front. }

1 Like

Your gateway's garbage collection algorithm choice is terrible. Remove those settings from ignition.conf. You want it to use the default G1GC. Also set the target pause for G1GC to ~100ms.

Your client chart shows a very light load. Very unlikely to be a client problem.

1 Like


Thank you for your help. How can I remove those settings from ignition.config? See the attached pictures of my ignition.conf

See this post:

Note that you must explicitly set G1GC in java 8. It didn't become the default until java 9.

You are missing the line that actually activates G1GC.
You are deleting unrelated parameters (10-14). Probably should leave those there.
You will end up with two sets of memory limits. Don't do that, either.