ControlLogix UDT Tag Members Appear as Folders

Has anyone seen the situation where a UDT tag created in a ControlLogix (L72, v19) appears with some of the members (not arrays) showing as empty folders instead of tags in the OPC browser? From what I’ve seen, this occurs only in a few instances of the tag type. On the RSLogix side, everything appears OK. On the Ignition OPC side, some instances of the same type are fine. Tried deleting and recreating the tags in RSLogix - fixed itself it in once instance, did not in another. Not sure if this issue is on the A-B side or Ignition side. v7.4.1.

1 Like

Rebooted Ignition server and this issue went away. :scratch: If I see this again I’ll try re-starting the driver module.

1 Like

You might just need to use the “Refresh Browse” action link next to the entry in the device list on the gateway.

1 Like

I should have mentioned that refresh browsing does not fix this. I tried refreshing many times to no avail.

I’ve had the same problem. I figured mine was due to downloading a new program with a change in the UDT. I added two reals. One came across OK and the other came in as a folder. I refreshed browse with no effect. I edited the device and saved again with no effect. I finally updated to 7.4.2 and problem went away. My processor is an L73 with version 19.

Just as a heads up - this problem still exists in Version 7.4.2. I downloaded a new project to the PLC and new tag structures/members came up in the OPC browser as folders. Error in log says unable to parse template.

I saw this issue again today on 7.4.2 after a ControlLogix UDT was modified and downloaded to the controller. Tried refreshing the A-B driver via the gateway and that didn’t work. Restarted the OPC-UA server and all is OK.

I would like to see the cannot parse template error in the logs.


  • Set the ABControlLogixBrowseRequest to trace.
  • Refresh browse for the device and wait for it to finish.
  • Turn off the trace.
  • send in your logs.

Thank you,

If I see this again, I’ll do my best to get you a log. Since it seems to happen randomly, it may be awhile.

Thank you

If it happens again, also turn set ABControlLogixTagManager to trace.

Here is a log trace per requested above. The device is [CLGX2AMC].

The BOOL type tag that shows up as a folder is in the Global folder, it is: “B4A_Size_confrm_HOut”

Please let me know if I can help further on this. Thanks.
logs.bin.gz (656 KB)

I am having the same problem. Have you come up with a solution?

Not yet. They gave me a beta OPC server with some custom logging features to capture this. Unfortunately, I have not seen it happen since.

Hopefully, we’ll do more tag downloads into ControlLogix soon and can trap an instance.

Unfortunately, we are still working on it. It is a intermittent problem and are unable to reproduce it in-house.

If your system is in the state where tags are showing as folders and you can take the time to call in to tech support, it will help use narrow in on the problem.

Otherwise, we’ll keep you posted.


There is a new 7.3.8 beta3 release available on our downloads page that should address this issue. You should just be able to install the Allen Bradley module to fix this issue. If you still have problems after installing the upgraded module then please let us know.

Unfortunately, it appears that a variant of this is still with us, though it wasn’t in a UDT. A ControlLogix DINT tag (1 of 2) was added today that showed up as a folder. This is an L72 v19 ControlLogix controller. I’m running Ignition 7.5.3 on Ubuntu 11.10 64bit. The A-B driver is 1.5.2 (b241). I re-started the OPC-UA module and it corrected itself. My apologies for not getting a trace of this. We’re under the gun to get a project operating, but I did want to report it.

The most recent release of Ignition, 7.5.4, includes the newest Allen Bradley driver. Try upgrading to this release and let us know if it resolves the issue.

I am running Version 7.6.4 and I ran into this same exact issue. I needed to restart OPC-UA as stated in this post and it fixed it. Has this not been fixed yet I take it?


[quote=“drewdin”]I am running Version 7.6.4 and I ran into this same exact issue. I needed to restart OPC-UA as stated in this post and it fixed it. Has this not been fixed yet I take it?


Since upgrading to V7.6.6 I have not seen this issue , as I too experienced.
BUT, in V7.6.6 the export of UDT tags is broken. This has been acknowledged by Tech Support.
You have to export all the tags and strip out the UDT tags from the .xml or .csv file.


This is more than likely a separate issue since the original issue posted in this thread had to do with a much older version of Ignition. I would encourage you to start a new thread with your issue.

The issue you are having, can it be reproduced? I rarely see an issue like this. Sometimes the tags get caught in a weird state and a restart of the Allen Bradley driver or the OPC-UA module will get it out that state.