Downloading Ignition on a Headless Server

I was trying to install Ignition on a headless Linux server today and ran into a problem where I couldn’t download the installation file. My guess is that the download link I copied to use with “wget” was rejected since it wasn’t being selected from the browser the got the link. Which is fine and all, but it was a hassle to download the installation file and then upload it to my google drive and download it from the the google drive onto the headless server. Is there a direct way to download Ignition directly from headless servers?

Set the referer to “”:

curl -L -O -H 'Referer:'

Got this when trying to download the 8.1.9 linux installer. It worked ok for the Windows installer, because I accidentally downloaded that one first. :roll_eyes: No big deal, as I can download it elsewhere and transfer it over.

curl: (60) SSL certificate problem: self signed certificate in certificate chain
More details here:

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

No problems here… are you on a work network with a nosy appliance or proxy?

kevin@kevins-mbp ~/Downloads> curl -L -O -H 'Referer:'
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1550M  100 1550M    0     0  15.6M      0  0:01:39  0:01:39 --:--:-- 15.9M
1 Like

Work network. Old infrastructure, so probably noisy. lol.

Actually, I take that back. This is in a new facility with new infrastructure. Again, not a big deal, as I’m transferring it now.

This did the trick for me.

wget --referer=

Another way.
Install links2, and navigate in a text browser, might work that way, have not tested it my self.
But this has always been my option in such cases when you need the correct referal page to do something where wget fails.

I have downloaded the certificate public key first. Then added the public key to the wget with
--ca-certificate=files-inductiveautomation-com.pem which did the trick for me.

Not sure why you would want to download the certificate but not the installer itself is a question, but this may have its own use case :slight_smile:

I was sick of doing this all the time for upgrading ignition, so I created a script to do it.


# download the latest version of ignition
echo -e "Go to this web page, and paste in the download link. \n\n"
echo -e "Download Link: "
read httplink
nlines=$(wc -l < $httplink)

filename=`echo "$httplink" | rev | cut -d'/' -f1 | rev`
echo -e "filename: $filename \n"

echo -e "Downloading from: $httplink \n"

####### Enable when ready
wget --referer= $httplink

echo -e "Making file executable.\n"
sudo chmod +x $filename

echo -e "Running Installer.\n"
1 Like

So I ran into an issue last year ~September '21 with this for my companies auto install and configuration through ansible. Essentially it boiled down to the fact that IA had changed certificate authority to Zscaler and on RHEL 7.* servers that CA wasn’t in the standard ca-trust files. After adding the Zcaler root certificate updating the trust I was able to get the downloads to work again.