Error in your SQL syntax

Hi
we stop our gateway for 3 weeks. when i run it again i found a lot of errors and all of trends not working.
even when i make a new trend with generic tags .i receive below errors.

[code]Exception: Error running query:
TagHistory(paths=[M01223/PH RO1, M01223/PH RO2, M01223/PH RO3, M01223/PH RO4, M01223/ORP RO1, M01223/ORP RO2, M01223/ORP RO3, M01223/ORP RO4, M01223/Cond RO1, M01223/Cond RO2, M01223/Cond RO3, M01223/Cond RO4, M01223/Permeate Flow RO1, M01223/Permeate Flow RO2, M01223/Permeate Flow RO3, M01223/Permeate Flow RO4, M01223/Reject Flow RO1, M01223/Reject Flow RO2, M01223/Reject Flow RO3, M01223/Reject Flow RO4], start=Mon Feb 18 17:53:13 AST 2013, end=Mon Feb 18 17:58:13 AST 2013, flags=0)@5000ms
On: Trends .Root Container.Easy Chart
caused by GatewayException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘OPTION SQL_SELECT_LIMIT=1’ at line 1
caused by MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘OPTION SQL_SELECT_LIMIT=1’ at line 1

Ignition v7.5.5 (b1255)
Java: Sun Microsystems Inc. 1.6.0_32
[/code]
attached export logs file from console. Plese advise
Tamer
logs.bin.gz (471 KB)

Please check attached error screenshoot


I think these errors look familiar, did you happen to upgrade to MySQL 5.6 recently?

Yes i upgrade MYSQL to the new version. ?? How can i solve the problem?
Thanks for your support
Tamer

MySQL 5.6 has some internal changes that don’t interact with the old JDBC driver and Ignition historian system very nicely. You’ll have to upgrade to the new JDBC driver. Start by downloading the zip from the ConnectorJ download page:

dev.mysql.com/downloads/connector/j/

Extract mysql-connector-java-5.1.23-bin.jar from the zip, and place it somewhere on your hard drive. To install the new jar you will go to the Ignition gateway homepage, click the Configure Tab, and then click Drivers under the Databases header. Once there, select edit next to MySQL ConnectorJ. In the JAR File(s) section select choose file, navigate and select the jar file that was extracted from the zip. Then save the settings on this page. If that doesn’t fix the issue, let me know.

Hi James,
Perfect. It working now.
Thanks for your support :thumb_right:
Tamer