Gateway backup is huge

For some reason our Ignition Gateway backups are huge.
For example 12.08.2015 it was 120mb, 18.08.2015 is 420mb and today it is 1100mb.
And it takes a lot of time to make this backup.
Also we were unable to restore any of those backups on other server with Ignition.
Project backup size is 7,5mb.
Ignition version is 7.7.5.

Other our Ignition servers gateway backups size is much less. For example our oldest project is more than 3 years and really big. It’s gateway backup size is only 42mb.


This is a known issue we are working on. It clearly shouldn’t be that big. Until we have it solved, there is a procedure to shrink the size but it’s a bit involved. I’ll look into making a tool for it so it can be done on-premise.

Good to know.
Maybe we can upgrade our Ignition version or downgrade for a moment until this problem is solved?
How can I obtain this tool?
Will the backap be restorable after use of this tool?
Because at the moment it is not restorable and it is a big problem.

We’re working on the tool now. It won’t work on the gwbk, but from a data/db folder itself.

If you need to use it on a gwbk you could just unzip it. When we have it done we can send it to you, and maybe we can walk you through it on the phone if you’re available

Here is a link to the zip of the tool. Unzip and you’ll find a readme with usage instructions and a jar to run. As always, make sure you create a full Gateway Backup before using. …

Note: This isn’t a general optimization tool, but should help those who have seen internal database sizes and backups grow abnormally large in 7.7.

Please let us know how it works for you.

What is causing the increase? I had the same issue. I was using a SQL Db and switched to Internal Tags. In the process of doing that, I updated Ignition. My gwbk went from under 300 mb to over 1.8 gigs!

Pretty sure switching tags didn’t have anything to do with it - it was the upgrade. We updated the version of the internal database that stores Ignition’s settings and this new version has a bug with storing BLOBs, which we use to store the projects.

We’re working with the author of that internal db to get the problem solved, in the meantime, the shrink tool is the workaround we’ve got.

This issue about it being a problem with the projects would explain why our Development server is also experiencing this issue. It went from around 20MB to over 800MB with the dev work being done on it lately. The big issue we noticed is that with the internal DB settings of taking a backup every 2 minutes it slows down the system considerably. Hopefully this gets fixed soon. Also does this mean 7.8 is affected with the same bug?

Yes, 7.8 has the same issue unfortunately. One thing that can help is to simply turn off the autobackups entirely. They aren’t really needed, especially if you’ve opted into the scheduled backup system so you can control when backups are made.

To disable auto backups, shut down the gateway, edit your data/gateway.xml file, and set the “localdb.autobackup.count” property to 0.

We have ran this tool on our development box to help with the issue there, however we keep getting this error message popping up and the tool doesn’t run correctly. Any ideas on what might be causing it?

Ignition Version 7.7.5

SQL Server 2012

Sorry the previous version didn’t work for you. I’ve made an adjustment to hold larger resources, so give the attached tool a try and let us know how it goes. …

We getting closer to a fix?

A fix was committed for the next version of the internal database, but has not been released yet. We don’t have a timeline on when the release will be available to us, but it will be tested and integrated into Ignition as soon as we can. I’ll try to keep this thread posted when I know more.

Great! :slight_smile:

Perry, I tried the new version that you linked to and unfortunately I get the same error message. Our DEV server is functional but runs slows still. We are also able to take backups of the gateway but now they are over 1.2GB in size. Looking forward to the new internal DB version.


Sorry to hear you didn’t have any luck with that version. I recommend getting in touch with support. They have some experience troubleshooting some of the issues and if nothing else can help us collect more information on ways to improve the tool to improve it.


We use Ignition-db-shrinktool.jar to compress our db and it resolve the problem.
Recently, we upgrade Ignition to 7.7.6 (b2015120217) and now the shrink fail, i don’t understand why.
Is it still necessary to use shrink tool with this new version ?

I think the gateway must be stopped while the shrink tool is run.

It was

According to the Change Log it doesn’t look like 7.7.6 has the new fix in place. What version of Java are you using? I know we tested out version 8 update 66 and that caused issues with the gateway so we are still running update 51 for now.