Gateway is Faulted, Web server is running

While attempting to restore the Inductive university backup, the GCU reported that the Gateway is faulted. I cannot seem to find any indication that is wrong? Any help on this matter would be appreciated. To clarify

Check the wrapper.log, in Program Files/Inductive Automation/Ignition/logs/wrapper.log. If you’re not sure what you’re looking at, feel free to upload the file here.

1 Like

I am unable to load the file being a new user, however, I believe this is the issue?

Yeah, that’s it. There was something wrong with the gateway backup, so the restore process failed - which left a file hanging around that’s preventing future startup from working. If you delete the ‘restore__disabled.gwbk’ file in Inductive Automation/Ignition/data you should be able to start the system correctly.

1 Like

Thank you! That seem to have fixed it. Just for future reference, which line exactly indicated this was the issue? I’m looking at the language and I’m not entirely sure?

The key line is the ‘Error during context startup’. Because I can cheat and look at the source code, I can then use the stack trace on the next few lines to know what the system is trying to do at that time, and figure out what went wrong. Mostly this is just a piece of institutional knowledge, though - anyone in our support department would also have been able to help out. It is a fairly cryptic error on the scale of things, though, which we try to avoid; it’ll get reworked at some point in the future.

Mine has done the same thing as above.

Yours is a different underlying error. You need to update your MySQL JDBC driver.


The problem I’m having is that the gateway doesn’t start. Just the web server, the gateway attempted to start but it goes to faulted and then stopped state or just tries to start and then it stops.

I started “Anydesk” application and the running Ignition application- Vision Client crashed. I tried re-installing Java, Ignition, Designer, Vision client but nothing helped to restore the system.

Uploading the wrapper.log file. Kindly guide, how to restore the Ignition Gateway, Designer & Vision Client.

3 posts were split to a new topic: Unable to start gateway