Gateway Not Starting

My gateway would not start up this morning. This may be tied to when I had to change the password on my laptop recently, not sure if I’ve run the gateway since then. What I’ve tried to so far:

  1. Browsing to localhost: 8088 tells me that the site can’t be reached.

  2. Trying to start the Ignition Gateway service errors out and says to check the System Logs.

  3. Opening gwcmd from the command line starts and freezes as seen in the image

  4. Checked the wrapper log, and get the following error when trying to start the Gateway service:

STATUS | wrapper | 2020/01/10 10:58:05 | → Wrapper Started as Service
STATUS | wrapper | 2020/01/10 10:58:05 | Java Service Wrapper Standard Edition 64-bit 3.5.35
STATUS | wrapper | 2020/01/10 10:58:05 | Copyright (C) 1999-2018 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2020/01/10 10:58:05 |
STATUS | wrapper | 2020/01/10 10:58:05 | Licensed to Inductive Automation for Inductive Automation
STATUS | wrapper | 2020/01/10 10:58:05 |
ERROR | wrapper | 2020/01/10 10:58:06 | Unable to execute Java command. The system cannot find the file specified. (0x2)
ERROR | wrapper | 2020/01/10 10:58:06 | (null)
STATUS | wrapper | 2020/01/10 10:58:06 | ← Wrapper Stopped

And ideas on what to do next? This is a development machine, so I’m ok with reinstalling if needed. Full wrapper log emailed to support@inductiveautomation.


It looks like your install failed to unzip the jre runtime. In your install directory go to /lib/runtime and there should be a zip file called and extract that zip in the runtime directory so now you have a jre-win folder inside /lib/runtime. From there try and start up the gateway again.

That did the trick. Any idea why this occurred now? It’s been installed on my laptop for months, and I haven’t made any installation-level changes recently. Interestingly enough, this same error appeared on a separated work laptop where I was prevented from installing Edge. Both errors appeared at approximately the same time.

Overzealous IT/security program deleting any Java installation it finds, maybe?

1 Like