[IGN-4846]Rename Tag Providers in cloned project

Hi at all,
i have a question :
I have created a project in ignition (vision) and the tags in the whole project are tied to the tag provider [default].

in the same gateway I have to create another project, starting from this one, and then I created another provider tag referring to the new , named [ciptags].

Opening the new project (clone of other), i imported tags from [default] to [ciptags], and i tried to rename with find / replace [default] with [ciptags] in all project, but I had problems with templates and had to re-run the find / replace command several times. Some templates return an error and do not connect correctly even if the path is correct.

What is the correct way to rename the provider tag throughout the project?

I use Ignition 8.1.9 vision

Thanks

I’ve seen something similar as well. If you go into your templates and check your binding values, are they looking at the correct tag or still using the old tag path?

For me, I was using 8.1.5 and for example had a Template that had a few properties defined, 2 of which were:

  • parentTagPath (Template parameter)
  • tagPath (Internal custom property)

tagPath was bound to an expression that used parentTagPath. I used find and replace to replace parts in the parentTagPath, but the tagPath never updated. The parentTagPath was showing correctly renamed. I tried saving the template, restarting the gateway to no avail. The only thing that I found to fix it was to re-save the binding on tagPath - no change to it, just open it and press OK. Then it came good. I had to do this MANY times…

I posted the bug here:

Yes is correct path, but not work…
Then have you found the correct way to do rename tag provider?

I only had a few references to my default tag provider that I changes with find/replace, but most of my references imply the project’s default tag provider which I changed to my new tag provider.

Do you have a screenshot of an example of your bindings that aren’t working?

So in the tag reference paths around the project you have omitted “[default] xxxxx / xxxx” for only xxxxx / xxxx, so it use the default provider tag in the project settings?

Not now, i have restored gateway to try again, i will try and i will send :slight_smile:

Yep, instead of:

[default]Area/Pump 1/Status

I use:

Area/Pump 1/Status

which then takes the tag provider from the default tag provider configured in the Project properties under Tools.

Renamed inside the templates [default] with empty space, and as you wrote the binding is disconnected, I opened the template and just pressed OK to reconnect it.
In the screenshots the black template is disconnected, and the green / gray one is connected correctly, but they have the same type of path.
I think it’s a BUG to fix …. :sweat_smile:


@PGriffith

Okay, so just to make sure I’m getting the minimum sequence of events correct:

  1. (Indirect?) binding is set up to tag/path/A
  2. Find & replace is used to replace tag/path/A with tag/path/B
  3. Launching a client at this point, the binding will not evaluate correctly.
  4. Open the window, look at the binding in the designer, make no changes, save the window.
  5. Launch the client, window now works?

I’ll play around with it a bit - this thread has some possible red herrings re: tag providers, but my educated guess is that it’s not relevant and the core problem is find & replace affecting bindings.

Okay, I’ve been convinced there is a bug here and filed a ticket.

2 Likes

Cool, so you managed to reproduce it on your end? Otherwise I was just going to say

look at binding, press OK, making no actual changes, save window

2 Likes