Ignition Gateway not starting after long time

Hello Team,

Previously I was working with Ignition v8 and I did not use it for like 3-4 months. Suddenly when I tried starting Ignition Gateway or tried to launch a designer, it threw an error saying cannot reach site. I did some forum research and all. But none worked.

Hence I downgraded the version from v8 to v7.9 and after installation my gateway won’t start. It shows following error,

I tried to increase its Java heap memory size + I also tried to uninstall microsoft EMC, however I couldn’t find it in my laptop.

My laptop specs: Windows 10
RAM: 8 gb
Memory: 1 TB

Please see below wrapper log,

STATUS | wrapper | 2020/02/14 21:45:14 | Launching a JVM…
INFO | jvm 1 | 2020/02/14 21:45:14 | Listening for transport dt_socket at address: 8000
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager: Initializing…
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperSimpleApp Error: Unable to locate the class com.inductiveautomation.catapult.Catapult : java.lang.ClassNotFoundException: com.inductiveautomation.catapult.Catapult
INFO | jvm 1 | 2020/02/14 21:45:14 |
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperSimpleApp Usage:
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: Error in WrapperListener.start callback. java.lang.IllegalArgumentException: can’t parse argument number: app_class{/app_method}
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: java.lang.IllegalArgumentException: can’t parse argument number: app_class{/app_method}
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.text.MessageFormat.makeFormat(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.text.MessageFormat.applyPattern(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.text.MessageFormat.(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.text.MessageFormat.format(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at org.tanukisoftware.wrapper.WrapperResources.getString(WrapperResources.java:215)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at org.tanukisoftware.wrapper.WrapperSimpleApp.showUsage(WrapperSimpleApp.java:621)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at org.tanukisoftware.wrapper.WrapperSimpleApp.start(WrapperSimpleApp.java:465)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at org.tanukisoftware.wrapper.WrapperManager$11.run(WrapperManager.java:4330)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: Caused by: java.lang.NumberFormatException: For input string: “app_class{/app_method}”
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.lang.NumberFormatException.forInputString(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.lang.Integer.parseInt(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: at java.lang.Integer.parseInt(Unknown Source)
INFO | jvm 1 | 2020/02/14 21:45:14 | WrapperManager Error: … 8 more
STATUS | wrapper | 2020/02/14 21:45:16 | <-- Wrapper Stopped

Here is error of v8 also. I had to search it in the log file and found this,

STATUS | wrapper | 2020/02/11 19:45:04 | --> Wrapper Started as Service
STATUS | wrapper | 2020/02/11 19:45:07 | Java Service Wrapper Standard Edition 64-bit 3.5.35
STATUS | wrapper | 2020/02/11 19:45:07 | Copyright © 1999-2018 Tanuki Software, Ltd. All Rights Reserved.
STATUS | wrapper | 2020/02/11 19:45:07 | http://wrapper.tanukisoftware.com
STATUS | wrapper | 2020/02/11 19:45:07 | Licensed to Inductive Automation for Inductive Automation
STATUS | wrapper | 2020/02/11 19:45:07 |
WARN | wrapper | 2020/02/11 19:45:24 | Child process: Java version: timed out
INFO | wrapper | 2020/02/11 19:45:24 | Wrapper Process has not received any CPU time for 14 seconds. Extending timeouts.
STATUS | wrapper | 2020/02/11 19:45:24 | <-- Wrapper Stopped

Hi @gaurav_shitole,

Downgrades from 8.0 to 7.9 are not possible as there is a significant migration process of the necessary data that prevents it from working. If you need to run 7.9, then you would need to restore from a 7.9 .gwbk file.

As for what is going on with 8.0, can you elaborate how you updated and attempted to start the application? Did you use our installer or did you use the zip install? How did you start the application?

Based on what I am seeing in the logs, it is looking like the version of Java packaged with the application isn’t getting extracted from the install properly. The above questions will help identify why that is occurring.

One other thing to be aware of, the UI option for starting and stopping the application has been removed for 8.0. The command line utility gwcmd.bat is supported for 8.0.

Thanks,
Garth

Hello @ggross,

Thanks for the quick reply.

Yes regarding downgrading to v7.9, I did install v7.9 and removed v8 when it prompted newer version is already present and proceeding will replace it. I took a backup before it. Once designer of v7.9 is open, I was planning to import templates and screens individually. However as gateway could not start, I could’t do so.

About v8.0, yes I saw the Inductive University’s video before doing so. Please note that, I already had used v8.0 previously when I was able to open its designer. I even created perspective stuff in it.
Yes I opened a Gateway–> downloaded a designer app–> then from designer app, selected my PC and launched the designer for development.
Also i tried opening GCU of v8.0 from command line and also directly from installed directory (gwcmd.bat). It gave “Access denied” from that.

Thanks,
Gaurav

Based on what I seeing in your logs, something isn’t correct with how the application was installed. Did you install it via a .zip file, or did you install it via the Installer (.exe) we provide on the website? This information is important to start troubleshooting this issue.

Garth

Yes I installed both times with the .exe downloaded from your website.

Shall I re-install it with the .exe?

Please try the following:

  1. Make sure you have a backup of the project you intend to use that is appropriate for the version you are working with.
  2. Use the Windows Add/Remove Program option to remove Ignition. (This will make sure the services get removed appropriately)
  3. After the uninstaller completes, rename any remaining Ignition folders that exist from the original install.
  4. Make sure you have an appropriate version of Java installed if you are installing 7.9 (8 or 9 is supported). If you are installing 8.0, the appropriate version of Java is included.
  5. Run the installer which should create a clean install and automatically startup Ignition
  6. Verify that Ignition is running. if it is running then restore the backup.

This process will ensure that Ignition starts properly, is working before your Gateway is restored and narrows down what may be wrong.

Garth

1 Like

Okay thanks for the suggestions. I’ll do this tomorrow and update the status.

Also as I’ll rename existing Igntion folders now and if newly installed designer starts, can I delete those files or do I’ve to keep it? We it’s been renamed, I don’t think it will be accessible to newly installed ignition.

You can remove them when you are confident in your new setup. My main concern is losing work accidentally. Our uninstall process leaves certain files in place just in case.

Garth

Hi!
Started to make a new thread, then i saw this thread. The same situation here. Was running 8.0.12 and did not touch it for 2-3 months. It died by itself. Now i can not start the gateway. I have tried to uninstall it, deleted all the folders from “Program Files” and tried clean instlall from EXE. The 8.0.15 install does not start, the 8.0.12 installer installs ignition, but the gateway does not start then. Are there any workarounds?
Using Windows 2019 server x64.

Thanks in advanceIgnition8 start log.zip|attachment (27.5 KB)

Hello,

Please confirm that Ignition Gateway service is running or not.

Ignition service is not running. When i am trying to start the service, i have the error message “Windows coult not start the ignition Gateway on Local Computer For more information, review the system event log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1”.

Thanks

Look in the wrapper log file in the install directory.

Thank you for the reply. Wrapper log tells about not being able to use or configure java
wrapper.log (10.3 KB)

The linked logs are attached in previous message.
Isn’t Java included in ignition8? I have also last Java8 installed on the machine. Java is added into system PATH variable also.

Can you also upload one of the crash dumps referenced in the log? e.g. C:\Program Files\Inductive Automation\Ignition\hs_err_pid3460.log

I have a similar issue.
Trying to upgrade from 8.0.12 to 8.0.15 and the installer never opens (same with 8.0.14 installer).
I tried to upgrade to 8.0.13 but there was en error copying some jar files (same behaviour with a fresh install).

I’m using Windows Server 2012 R2 Standard.

Edit : Problem solved downloading a new file.

Tried to start the service once again and got the logs. There are also many ~1.5GB (Gigabyte!) dumps. These are not included :slight_smile:
Thanks

IgnitionLog.zip (146.5 KB)

@gljuk, is your gateway running in a virtual machine?
https://bugs.openjdk.java.net/browse/JDK-8238596
A duplicate of the bug pretty exactly matches your hs_err_pid file:
https://bugs.openjdk.java.net/browse/JDK-8238246

There’s a possible workaround mentioned until we release a version of Ignition that bundles a fixed Java version - in ignition.conf, in the Ignition installation directory, find the wrapper.java.additional section. Find the last index that isn’t commented out, and add a new item:
wrapper.java.additional.4=-XX:UseAVX=0.

Thank you so much! Got the gateway running now! Now i will try to update the ignition, since now i am running the version, that has been crushed by itselt, 8.0.12

Downloaded once again. MD5 checksums are the same for both files, so files do not seem to be corrupted. After starting the 8.0.15 installer i see ignition logo, then it dissappears and nothing happens. Are there any workarounds for this? Maybe it is incompability with Windows? We have Windows Server 2019 x64 installed on VM.
Thank you!