Ingnition Designer Launcher - Blank window

Hello all,

Brand new to Ignition. I am working my way through Inductive University Ignition online training now.

I installed the Designer Launcher (and the Vision Client Launcher - same issue) and when the launcher window opens, the window is blank.

I can see the outline of the Gateway it detected and I can even launch designer with the button I cannot read.

When I did the original install, it worked the first time. After I closed it, when I tried again I just get blank.

I uninstalled it, moved the setup file to the Induction Automation folder and re-installed and now it will not display at all.

Any ideas? I wish I could post a snapshot. I have the same issue with the vision launcher as well.

Thanks, Steven

Hi all,

This problem still persists. Any ideas on why the window would not display any of the text? No labels, no data, just outlines and controls.

Any ideas at all?

Thanks, Steven

Hi @steven.cox,

What environment are you running in? This sounds like an environment or possible a JavaFX issue.

Thanks,
Jonathan C

Thanks for the help Jonathan.

I am running Windows 10 Pro. On the Gateway Status page it reports Java Version 11.0.7+10-LTS.

I am using Ignition Version 8.0.16.

The Java installed on my system is Version 8 Update 251 (build 1.8.0_251-b08).

Thanks, Steven

can you check in you User folder for a .openjfx folder? It will be hidden. This is a cache folder, can you try deleting it while the launcher is closed and then relaunch it?

I deleted the file but each time I start the Designer or Vision Client Launcher it is recreated. Neither of the launchers display text.

When I installed them and they launched, it worked fine. Only subsequent attempts fail.

Any other ideas?

Thanks, Steven

Is there anything in the log file for the launcher? should be at C:\Users\YOUR_USER\.ignition\clientlauncher-data\LAUNCHER_NAME.log
If nothing really stands out (logged exception or warning/errors) i would get in touch with support

This is the most recent from the log file…

INFO [DesignerLauncher ] [2020/09/21 10:47:37]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 10:47:37]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 10:48:31]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 10:48:31]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 12:36:34]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 12:36:34]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 14:29:59]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 14:29:59]: Updating logging level to INFO
INFO [GatewayConnect ] [2020/09/21 14:30:12]: Attempting to connect to gateway http://localhost:8088
INFO [LaunchUtil ] [2020/09/21 14:30:14]: Starting Java with the following parameters: C:\Users\Steven.ignition\cache\resources\runtimes\11.0.7\bin\java.exe -classpath C:\Users\Steven.ignition\clientlauncher-data\launchclient.jar -Djavaws.sr.gateway.addr.0=http://localhost:8088 -Djavaws.sr.launchts=1600716614261 -Djavaws.sr.main=com.inductiveautomation.ignition.designer.DesignerStartupHook -Djavaws.sr.platform.edition= -Djavaws.sr.platform.plugins= -Xms64M -Xmx1024M -Djavaws.sr.memory.init=64M -Djavaws.sr.memory.max=1024M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false -Djavaws.sr.screen=0 -Djavaws.sr.scope=D com.inductiveautomation.ignition.client.launch.BootstrapSwing
INFO [DesignerLauncher ] [2020/09/21 16:04:07]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 16:04:07]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 18:29:31]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 18:29:31]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 18:31:07]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/21 18:31:07]: Updating logging level to INFO
INFO [DesignerLauncher ] [2020/09/22 14:02:54]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2020/09/22 14:02:54]: Updating logging level to INFO

I started the launcher today and only logged the last two lines.

See anything wrong?

Thanks, Steven

Nothing specifically. can you try something for me? I have uploaded a zip file which contains a file called designerlauncher.l4j.ini inside of it. can you place that file next to the designer launcher executable? Make sure its specifically the executable, not the shortcut (if you right click the shortcut you should be able to click Open File Location which will show you the original designerlauncher.exe file.)

designerlauncher.l4j.ini.zip (244 Bytes)

Once that is done try launching the designer launcher. It should look like this: image

That worked!! The Vision Client Launcher does not work and it does not have an .ini file next to it.

Should it? and do you have one?

Briefly, what is that .ini file for?

THANKS!!

Steven

you could copy that file to the vision client launcher directory and rename it to visionclientlauncher.l4j.ini and it will have the same effect.

I disabled Hardware Accelerated rendering here. This is usually not needed and likely means there is an issue with your graphical environment (Display driver or something else). I would recommend upgrading your drivers and performing Windows Updates (if there are any) and restarting to see if the launchers will load without the *.l4j.ini file.

Most of the time this is only required when running in certain VM environments that have graphical restrictions.

1 Like

Thank you so much Jonathan. That indeed worked. I will go and check for updates to make sure I am up to date.

Again, thanks for the help,

Steven

1 Like