Issue connecting to Allen Bradley PLC

I am trying to connect Ignition to an Allen Bradley PLC.

All it says is:
Disconnected: Protocol EIP : Unknown

Any clue what this means? Or, how to debug this?

What kind of AB PLC? What driver are you trying to use? Are there any messages in the logs?

I was told it is an Allen Bradley RSLogix.

I tried using the following drivers (none worked):

  • Allen-Bradley ControlLogix
  • Allen-Bradley CompactLogix
  • Allen-Bradley SLC

How do I find messages in the logs?

The logs are in the status section of the gateway.

I think this would best be handled with a call to support, though.

I would have to agree, because I am also fairly new to the Rockwell Automation software. I can possibly help you with this very soon, because it looked to be a familiar message on the Rockwell website. Things to bear in mind: RSLogix Studio 5000 software is what most folks use for versions above 20- that is a hint which relates to selection. The 5000 software pertains to certain newer models. It is used to program Rungs and Tags, etc. which an HMI would access. RSLinx Classic would still be used, but not for that purpose- and NOT on the same device driver -for example- they cannot both use the same Ethernet driver- one must use a different route. Re: Rockwell, FactoryTalk View Studio is a different & third piece of the puzzle. In the case of Ignition, you have an OPC-UA machine which can communicate- given the correct driver for Rockwell. You may need to call in a professional ( as many folks at the Ignition / Inductive Automation help desk are ) if you do not have any of the other software listed above nor a Rockwell account.O.K.- I misrepresented something here. FactoryTalk View includes RSLogix Enterprise, which is different than RSLogix CLASSIC. In order to run both on the same PC, you should have different drivers ie Ethernet or DF-1 etc. YET the same Port on the equipment or Network. The RSLinx Classic is used to allow uploads and downloads of rung logic to controllers such as PLC05 or SLC. The RSLogix Enterprise is included in FactoryTalk View Studio ME and is used to allow Applications to communicate with TAGs and data points in a PLC or Controller. Maybe that ( separate drivers yet same port connection ) will help.

Just a shot in the dark: Is the controller in “Run” mode as evidenced by the Keyswitch? If not, the last person who might have programmed it should be consulted. If that is NO ONE, then trying to extract tags might be the least of the EIP ( Ethernet IP, maybe? ) Protocol issues. There may be a password protection, thus turning the key may not be sufficient.

I appreciate all of your input. Here is a screenshot of the logs. Not sure if anything stands out to you? If not I can create a ticket

A few more clues: If there is a character-based LED display, it may tell you about the Internet Address(es) of various port(s). Remember that although you must be on the same subnet, you must have a different I.P. address in your PC configuration to talk to the PLC- and that you may want to look at examples where the subnet address (mask) is typically 255.255.255.0. Some are reserved for gateways and you may otherwise try a last digit away- example IP 192.168.1.1 for the PLC might yield 192.168.1.2 for your PC. Another rule of thumb in troubleshooting is to Step A. Get permission / insights from any company staff for: 1. Permission to disconnect PLC cabling from any adjacent switch or hub - 2. One last query about I.P. address that it may hold. 3. Permission to Power Cycle the PLC if needed. Step B. is to reboot your own PC and ensure that your I.P. and subnet address is what you intended after reboot- a cold start is best. Step C. is to watch LED character based display and attempt to connect as you had previously done. Step D. is to remember that you can try this again with your own switch or hub, apart from any network that was previously connected. Step E. would be a cold reboot of the PLC and another attempt. Step F. - Even if you fail, you need to remember that they might want you to reconnect the PLC to the switch or hub that it was on. I hope that this is not the case yet recommend leaving it connected in the case that they have remote support ‘ping’ or SMTP-type applications which could set off alarms should a device no longer be found.

This is not enough information. RSLogix 500 and RSLogix 5000 are two very different things. If you have physical access to the PLC, check model number. If you don’t, ask someone who does have access confirm.

Hey Matt, I can replicate this if I try to connect to a MicroLogix with the ControlLogix driver. Can you try using the MicroLogix driver to connect to your device?

Try using this one:
image

2 posts were split to a new topic: Connecting to 1756-L55 running firmware version 13