Modbus TCP write error

I have set up a Modbus TCP device, with the default settings, and can read any tag, but when I try to write to one I get error screen showing Error writing to 1_SP62.Value: Bad; unspecified and in the logs, Response fields did not mirror request fields. The value in the device does actually change but I would like to not have this error.

You’ll have to use scripting to do the write and suppress any errors yourself.

What’s happening is this device is not returning the correct response according to the Modbus spec. There’s no way to get the driver to ignore this and not return a bad quality in response to the write.

Thanks for the reply.
I thought that this would be the case. I did try to suppress the error with a try, but I still get the error popup.

I am having this same issue. I’ve tried this with a simple script using try/except but this doesn’t suppress the error. Is there another way to suppress the error?

Beware: jython’s Exception class is not related to java.lang.Exception, so if you specify one of them, you won’t catch the other. You often need two except clauses. Start here:

I was never able to suppress the error. I doesn’t cause any problems and it does write the value.