Native client launcher - Missing fullscreen mode

Dear Sirs,

i’m facing with a problem: Native client launcher with full screen mode.

What i’ve tried:

  1. On project properties, i’ve selected the “Fullscreen” mode, checked all 3 button (windowed,fullscreen, applet, to let them appear in the Start page)

  2. Downloaded “clientlauncher.exe” from Start page. Copy/pasted the /.ignition/clientlauncher-data/ folder near the clientlauncher.exe and modified the launch.xml with fullscreen (tried also with ‘windowed,fullscreen’)

  3. Tried to use default settings (on launch.xml) to open as window. It created the project exe correctly, then i changed the exe parameter “windowmode=fullscreen” but it opens as window.

Enclosed, you’ll find the specific error that the “clientlauncher.exe” gives.

What should i do? Thanks for the future help.


If you are using staging, did you publish the final settings?

Working with published project, not staging.

The project is already online, working as well. The fact is that i can’t create an icon (on the Desktop) for the final user.

I just want them to doubleclick on the .exe tu run the App, without passing through the localhost:8088/main/web/ page.

That’s why i need the client to start maximized.

I’ve tried another thing btw:
If i launch the app from the Start page (ignition gateway) from the button under the section “Launch Projects”, it runs maximized.
Instead, if i download the native client, connect it to the gateway and create a desktop icon, it won’t run as full screen.

Here are other images:

The native launcher looks like it is receiving project data that indicates that your project does not have fullscreen mode available. Try putting this URL into a browser on a client machine and see what it returns:

The native launcher uses the same URL to get project info.Maybe it can give some ideas on what the launcher is actually receiving.

Hello mgross,
that’s the url response: :slight_smile:

Maybe the project settings aren’t being published properly? Or the URL you used in the native launcher is pointing to a different gateway? I say this because I noticed that the max memory in the project settings is set to 512M, while the XML is showing max memory of 256M. So none of your changed project settings are making it to the native launcher. It might be time to send this over to Support to see if they can straighten it out.

I noticed, also, that default-launchmode is Windowed instead of Fullscreen.

The URL you gave me was copy pasted directly to the client browser, with “mygateway” changed to “localhost”, so, i think it can’t be an URL problem.

Are you going to send it over the Support or should i?

Thanks a lot, @mgross

It’s better if you send it in. Support can likely solve it much faster when you are talking to them directly.

Good Day, has there been a solution for this?