No fullscreen when launched from vision client launcher shortcut

Ignition 8.0.3
Windows 10 IOT Enterprise

Launching a vision client from the Vision Client Launcher in fullscreen mode works as expected. If I create a shortcut from the client launcher, and launch from the shortcut, it opens in windowed mode. I verified the setting is on fullscreen before creating the shortcut.
This is a problem, because I add the shortcut to the startup folder so the application will start upon boot up if there is a power loss.

I have tried this on four separate clients, all with the same result.

I had the same issue in 8.0.4

You have to modify the json file for the client launcher at the .ignition folder


you will see “window.mode” in there replace the null with “fullscreen” you will have to do this on all clients.

This is a bug and should be fixed at some point according to tech support.


That worked. Thanks!

Thanks, that worked for me too.
The path was


And the line to modify was (for me) line 30.


      "window.mode": null,


      "fullscreen": null,

Good morning.

This issue still occurs in Ignition 8.0.6.

Does anyone know when it will be fixed?

Best Regards.

The window.mode in v8.0.6 is automatically managed by the ClientLancher: you just need to “Manage” your application, change the window mode accordingly and then save. This action will automatically update properly the json file

Just want to confirm that this is still a bug in 8.0.7. Even using the “Manage” option in the vision client launcher does not set the vision-client-launcher.json to fullscreen.
Just to clarify the current fix, as there is conflicting info above, you just change the following line in C:\Users\user.ignition\clientlauncher-data\vision-client-launcher.json

"window.mode": null,


"window.mode": fullscreen,


Im not able to reproduce this. Could you provide more details about this? Are you adding the argument to the shortcut for fullscreen or are you setting the window mode in the Vision Client Launcher to fullscreen then saving it through the manage option? The launch button should reflect the new mode as well:

I tested this with a launcher from 8.0.5 so it should be working in your 8.0.7 launcher assuming you updated the actual launcher on your system and not just your gateway. You can check the version of your launcher in the about window

Jonathan C

Tested using launcher from 8.0.6 and 8.0.7. I’ve just done a complete new install, removed the .ignition folder and started again.
The project is set to only be runnable fullscreen, with no menu bar. On initial launch from the client launcher using the Launch and Create Shortcut in the dropdown, the client successfully runs full screen with no menu bar.
If I then close down the client and restart it using the icon that was created on the desktop I get full screen but with a menu bar:

Here are the contents of visionclientlauncher.json:

  "global": {
    "default.application": "",
    "multicast.address": "",
    "multicast.receive.port": 4446,
    "lock.configuration": false,
    "logger.level": "INFO",
    "client.defaults": {
      "timeout": 30,
      "retries": -1,
      "init.heap": null,
      "max.heap": null,
      "use.custom.jre": false,
      "custom.jre.path": "${JAVA_HOME}/bin/java",
      "jvm.arguments": [],
      "client.tag.overrides": {}
    "autoexit": false
  "applications": [
      "project": "Line1Overview",
      "allow.windowed.launching": null,
      "allow.fullscreen.launching": null,
      "name": "Line 1 Overview",
      "description": null,
      "main.class": "com.inductiveautomation.factorypmi.application.runtime.ClientLaunchHook",
      "": {
        "": "xxx",
        "gateway.address": "xxx",
        "redundant.gateways": []
      "window.mode": null,
      "timeout": 30,
      "screen": null,
      "retries": -1,
      "init.heap": null,
      "max.heap": null,
      "sun.java2d.d3d": null,
      "sun.java2d.noddraw": null,
      "jvm.arguments": [],
      "last.updated": 1578679435360,
      "client.tag.overrides": {},
      "image.path": null,
      "fallback.application": "",
      "use.custom.jre": false,
      "custom.jre.path": "${JAVA_HOME}/bin/java"

You can see window mode is null, changing the null to fullscreen then enables the icon to launch full screen without the menu bar.

I may be confusing things with my incorrect terminology, the client is actually launching in window mode rather than fullscreen, forget my mentioning of the menu bar.

I’m experiencing the same issue:

The shortcut created by the “Create Shortcut” option for my “Fullscreen” project results in a shortcut that launches in windowed mode NOT fullscreen mode. This is v8.0.7

We experience the same issue with some of our Clients. Any news/ workarounds?

We’ve never had an issue creating shortcuts that launch full screen using Ignition 8.0.7 client launcher version 1.0.7 by going to manage the client (menu pops up when tapping on menu icon to right of app name in client launcher), setting Window Mode to fullscreen, and then tapping the Create Desktop Shortcut button the right:

Does doing it this way work for you?

speaking for ericleisebein:
starting the application right from the launcher does work. creating the shortcut and starting it from the shortcut does not work. either creating the shortcut inside the property-screen or directly by the button on the main screen: result is always the same.

Hello all,

I have identified what appears to be the root cause of this and I have a fix pending. We will update this thread when the fix goes into the code base.

Jonathan C


This fix was added to 8.0.10, and will be available in the next 8.0.10 nightly build.

I’m on 8.0.10 and still experiencing this issue.

Have you downloaded and installed the client launcher from an 8.0.10 gateway? The launchers are a separate application, so even if you updated your gateway, your local installation of the launchers could be out of date.

No. That would explain why some clients work, and others don’t. Thanks for pointing that out.

1 Like

I’m having this issue still on a brand new install (Ubuntu VM) using 8.0.12.