onFileReceived call twice on FileUpload component

Hello
I put a FileUpload component in a view and try to upload a single file. In onFileReceived event I simply print some info on console.
Every thing works just fine except the event fire twice each times I upload a file.
If I try to load 3 files for each file the event fire twice so I totally have 6 fire event for just 3 files.

Hey Nader,

I was having the same issue!

@jball Looks like i’m not the only one with this problem

1 Like

@nader.chinichian, @Matthew.gaitan, thanks for reporting. I’ll log a bug so we can diagnose. For documentation, can you let me know the versions of Ignition you guys are on?

Is there any chance one of you could send either Josh or myself a View (view.json) which is experiencing this issue? Or post one here?

Here is the view. Hope this helps!

test.json (4.4 KB)

Edit: We’re on 8.0.11 RC1

My client use 8.0.6.

TOTAL_2020-05-09_0957.zip (4.8 KB)

Hi
Can you confirm it is bug or we made something wrong?

Cody and I both tried to replicate this in the past when it was first reported, but weren’t able to create the behavior. Hopefully with the views you and Mathew provided, we can create an example that exhibits the behavior so we can diagnose it.

By any change did you test it in v8.0.6?

Seeing same issue in 8.0.12

@nader.chinichian, @Matthew.gaitan, Cody and I tried to replicate this behavior with both of your views and were unsuccessful. The component and the eventing worked correctly in both cases. Cody did test on 8.0.6 to rule out that particular version of Ignition as a culprit. I don’t believe the issue lies in the component/view configuration.

Just to rule cache out as an issue, can you clear your ignition cache and retest?

https://support.inductiveautomation.com/index.php?/Knowledgebase/Article/View/112/2/how-to-clear-client-ignition-cache-and-java-cache#clear-client-cache

1 Like

I cleared out my local cache and am still having the same issue.

Is there any cache or anything that may possibly need to be cleared out on the gateway?

1 Like

By “local cache”, do you mean the Ignition client cache (from the article in the link above)?

yes. the .ignition folder located within my user directory

Darn; that’s a shame that didn’t work. Other things to try:

  1. Clear all browser cache.
  2. Restart the gateway.
  3. Test in an icognito window (following a gateway restart).

Upon importing my test.json file i uploaded for you guys the view didn’t have the same issue. I had tried this previously but seems like clearing the cache was the key.

Thank you for the help!

Hi Joshua
If clearing cache solve the problem can you make it independent from it?
In future I can’t control end users computer cache.

1 Like

Clearing out the cache resolved the issue for me too.

And agree with @nader.chinichian ,would be helpful to make it independent of cache.

1 Like

When you say cache, was it browser cache, or the ~/.ignition cache folder?