OPC-UA Maximum amount of subscriptions

Ignition 8.1.21

I am trying to add a PLC to my system that has its own OPC-UA server built in. I have added two of these types of PLC with their own OPC-UA and they work just fine. I set this 3rd PLC up the exact same way as the others so I want to believe my problem is not on the PLC side.

in the OpcUaSubscriptionSynchronizer logs I get two different types of errors.

	Failed to create subscription 'tag-group-default_alarming': status=Bad_TooManySubscriptions, description=The server has reached its maximum number of subscriptions.


subscriptionName=tag-group-default_alarming, ignSubscription=com.inductiveautomation.ignition.gateway.opcua.client.connection.OpcUaSubscriptionModel$IgnitionSubscription@30424c9a, opcSubscription=null

Are there any settings I am unaware of that could be causing these problems? My OPC-UA server is set to allow 10 subscriptions. On my PLC's webserver I only show 2 connections.

Another note: I only have 120 tags in this OPC-UA server spread over 7 tag groups. About half my tags work and another half are "uncertain_LastKnownValue". Maybe I have too many tag groups?

Each tag group gets its own subscription, so yes, probably too many.

I got all my tags into 3 groups but was still getting the same logs. The client page in the OPC Connections status page showed this.

I restarted all the tags in the designer, restarted the OPC-UA module, and re-configured the endpoint for my OPC server. I still show those few tag groups with 0 tag count but maybe it doesn't matter? No errors in the logs so far. I will wait it out a little longer before I mark resolved.

So I am still getting the "too many subscriptions" log. How do I get rid of these tag groups that are shown in the OPC connections status page? Four of the groups show a tag count of 0, yet I believe Ignition is still counting them as a subscription.

Have you gotten rid of the tag group entirely? And restarted your OPC connection?

I have restarted my OPC connection and fully deleted the tag group. Still no dice.

My other OPC servers from the same brand of PLC work just fine with 7+ tag groups so it is strange that this one is acting up. I'd like to believe it is not PLC side since it is set up 100% the same way.

Are there other systems also connecting to that PLC? Maybe also need to restart the tag provider? (Grasping at straws, here. Total gateway restart?)

As far as the OPC server goes, no. I have been the sole person setting it up. Just restarted the tag provider. Same result. I may be able to restart the gateway soon so I will try that.

Is there a limit on how many OPC servers a particular tag group can be used for? This is OPC-UA server #6 in the gateway.

No, no limit. At least, none imposed by Ignition.

I'm starting to think something is conflicting with the subscriptions, or something is getting stuck. I changed a few misc settings for the OPC server, clicked save, and then the tag group that was previously bad, is now good, and vice versa. Ignition is currently the only thing communicating with the OPC-UA so I am very confused to say the least.

Take a look at the server diagnostics and see if there are any other sessions, and how many sessions per subscriptions there are.

You should be able to view them by finding this connection in the Ignition Gateway status section and then clicking the “server” diagnostics link next to it. Or use the diagnostic view in a 3rd party client like UaExpert.

Cannot enable server diagnostics directly in the gateway because the OPC server does not support it. Looked at the server diagnostics in UaExpert. I am not quite sure if the built in server diagnostic "tags" even display accurate information. Here is a picture of the "serverdiagnosticssummary".

Tells me the current subscription count is 0. I checked the diagnostics summary for the working OPC-UA servers and they read all 0s as well. Not sure if the diagnostics for this OPC-UA server work at all.

Just found out something very interesting. I was able to restart my gateway today and now my OTHER new PLC (that has the same OPC-UA config) is the one showing the "too many subscriptions" log. The one that was having issues before is now working just fine.

Another observation I have made is that I have a tag group called "Alarming" and it is the ONLY tag group that is throwing this error. At the worst I suppose I can delete the tag group but I would have to change the tag group of thousands of tags.

My alarming tag group has a "custom property" of some sort called opcrate. Our gateway at one point used to be 7.9. I found this forum post showing that this was a bug when upgrading to 8 from 7. Was there ever any weird behavior resulting from this?