OPC-UA to RSLogix5000 Emulator?

We are hoping to evaluate the Ignition product by using it as an HMI to monitor tags in a ControlLogix PLC. Before we set up hardware, we’re using RSLogix5000 Emulator to simulate the runtime ladder logic. And we have RSLinx running on the machine. And Ignition. All on one laptop (Win7).

We tried setting up an Ignition OPC-UA service to monitor tags on the Emulator. Couldn’t get this to work (status said wouldn’t connect/time out), and didn’t know what to enter into the “Connection Path” field. Will Ignition work with this Emulator software?

When we set up our ControlLogix PLC (hardware), will the connection path be its IP address?

Backing up a step, should we be configuring the OPC-UA service in Ignition, or should we be using an Allen-Bradley “Module”?

Thanks for any tips to get us started on the right path. We’re eager to see what Ignition can do and as always the first day of use is the hardest…

1 Like

The ControlLogix driver doesn’t work with the emulator software, sorry. You’ll need to connect to real hardware, and when you do, the IP address will go in the Hostname field. The connection path is for drilling down into a backplane and getting to another CPU, etc…

If you’re connected directly all you need is the IP address in the Hostname field.

I’ve had some success in setting up an OPC Server in Ignition, then using RSEmulate 5000 to talk with Ignition that way.

Could you expound on how you did this?

I have two OPC server connections on a fresh install of ignition:

  1. Ignition OPC-UA Server
  2. Production

When I try to add a new ControlLogix device I put in the IP address of the PC with RSLogix Emulate 5000 in the Hostname and the slot number of the emulated PLC in slot number. It gives a “Disconnected - Protocol: EIP - Unknown”

I’d be very interested in hearing how you were able to get it working!

RSEmulate 5000 cannot communicate over Ethernet; SoftLogix 5800 can, but not the Emulator.

The only thing it can communicate with is the RSLinx Classic virtual backplane driver.

Therefore, any communications with RSEmulate 5000 have to be done via OPC-DA 2.05. You can’t connect to it with the Ignition OPC-UA server.

The original poster might have had an activation problem; RSLinx Classic has some limited-funcitonality activations that will allow the OPC Test Client and RSView software to be clients, but won’t respond to client connections from anything else.

I was actually wondering the method tpenke63 used that he stated was successful.

I do have RsLinx Classic Gateway and have configured it it with an OPC topic pointing at my emulator. I have not heard of OPC-DA, but if it can integrate with ignition and communicate with the RSLinx Remote OPC Server then I’ll try to learn it! :smiley:

abishur, When you create a new OPC server connection in Ignition, you are given a choice of “OPC-UA Connection” or “OPC-DA COM Connection” - you need to choose the latter. Here are instructions for setting up the DA connection: http://www.inductiveautomation.com/support/usermanuals/ignition/index.html?connecting_to_opc_classic_com.htm. Your DA server is what will be connecting to your device (the emulator), so you will not be creating a device connection in Ignition.

Ah, so I would need to install it on Windows instead of Linux in order to get the OPC-DA option, oh well. Thanks for the response!

Hi Yes its true,Ive tried setting up RsEmulate 5000 communicate with Ignition 7, provided both the gateway & the OPC reside on same PC…

1 Like

Hi Choy, can you show me how’s your OPC DA Configuration or your RsEmulate configuration please?

This knowledge base article should get you up an running.

Read me

You need to setup OPC server connection type just see the screenshots below.

2 Likes

You may find this thread helpful.

Cheers

Just Setup like that and it is tested to communicate to RsEmulate my side Im Using RsEmulate5000 and Ignition 7.9.6

2 Likes

Very helpful…thanks!

2 Likes

This really saved my day!!!
Thanks!!!

I set this up like described above, but Ignition doesnt seem to be able to pull any values from the OPC Server. I see’s the RSLinx topics and i can navigate throughout all the parameter trees. But whenever I try to read one, I get either bad_notconnected or error_Nullexception.

I reset my dcomconfiguration per another related thread, but still no go.

1 Like

Maybe you solved the problem?

Did you find a solution to this? I’ve done the same and am still unable to view tag values in tag browser. Only see “Bad_NotConnected”