Perspective components and property editor panel missing

I cannot find the property editor panel in my designer. I tried restarting the Gateway and reinstalling the designer as well. still it doesn’t show up.
When i open the gateway in a different machine’s designer it works fine.
Is there any troubleshooting you can help me with?

It would probably be best to just reset the panels.

View -> Reset Panels

I tried that too

Reinstalling the designer doesn’t work because the workspace settings are cached locally in %userprofile%/.ignition. Delete the perspective-workspace.layout file and restart the designer.

it says the folder is empty

If you have ever launched a designer / client, then there’s a .ignition directory within the user folder that holds cached files. If the directory shows as empty, then it must be under a different user directory.

You can always just delete the .ignition directory and all the necessary files will be recreated upon next designer launch.

Clear .ignition cache

I tried running %userprofile%/.ignition in all the user profiles, other profiles don’t have that file

So you’re saying the .ignition folder is empty and doesn’t contain files? %userprofile% on windows navigates to the current logged in users directory. So if you launch the designer and then look for files within the .ignition folder for the logged in user, are there any workspace setting files?

My designer is running currently. I am even able to save the changes i do in the designer. But when i check the user profile there are no cached files. It is empty.

I also find that the designer does not close when i give save & exit. Only the view closes. I need to go to task manager and end task the designer

When you attempt to exit the designer from the file menu, just a view closes?


Do you see any errors within the client console (under tools)?

What happens if you’re in a different workspace? If you go to vision, create a window, and then try to exit the designer (from the file menu), does it just close the opened window?

error in the console

Ya only the vision window closes not the designer

Are you able to create a simple text file within that directory? Do you have any antivirus / file scanning software installed? Since the designer launches under your user, it should have the permissions to create the file, meaning that it’s very well possible that another application is blocking access since the designer is a java application (and it can be common for security software to restrict file access per process).

Yes i am able to create a text file.

I don’t have any antivirus installed.I am using windows firewall

And even the firewall is turned off

There has to be some other software restricting access.