Raspberry Lock-Up

This may be a Raspberry Pi issue and not Ignition’s, but has anyone else run into a problem of the Raspberry Pi locking up while running Ignition Client? I am testing a unit on our factory floor that will lock up about once a week and has to be turned off and back on to recover.

That sounds like a memory leak. You might want to look at the client’s diagnostics every so often to see if memory usage is climbing.

I run over 70 Rpis with clients without any issues like you mentioned.

What might cause such a memory leak? I’ve not looked at client diagnostics before. How do I access them?

Thanks! That’s good to know. I feel like it is a good solution because we expect to install over 60 here as well if this first one proves out.

Ansible is a good way to mass change files, updates, etc on them once you have several to maintain


From the help menu in the client.

Thanks. Good to know. I’ve never looked at the menu much at all in the client.

I have been monitoring the client’s diagnostics. It did locate an unknown error in a script about a missing tagname, but memory seems stable. I’m running an average of 45 MB, ranging between 35MB and 60MB. I’m still getting lockups

Additional information: I just started up workcell #2 and that unit, a clone of #1, already locked up over night.

Check your version of java on the pi, I think I use version 8. Before I had version 11 and I had problems with power tables. Worth a shot.

Thanks. But, I am using version 8. I just double checked after your suggestion to be sure.

It sounds like this is a project issue. Maybe upload a workcell version with certain functions disabled and see if you can pinpoint what is causing the lockup.

You said that you have over 70 Rpis with clients running. Is there anything you can share about your Rpi configuration? I still have lock-ups about once a week.

Zulu 8 Java
RPi 3b
32gb sd cards
autostart ignition client on boot from shell script
PoE comms
7" touchscreen and case

Other than that, I didn’t really do anything special with the setup that I can think of

Seems like only minor differences. I’m still on 7.8, I don’t have Zulu 8 Java, I’m using the RPi wireless and a 19" monitor with mouse. setup of rpi

What OS are you using on RPi?

cat /etc/os-release
Pretty_Name = "Raspbian GNU/Linux 10 (buster)"

I also have some Pis hooked up to 27" monitors via HDMI.

That’s a match on the OS. That’s not directly the problem. :frowning:

This definitely sounds like a memory issue. Have you tried monitoring the memory usage of your raspberry pi? If it is a memory issue, you could try a Rpi4, you can get them with 1, 2, or 4gb of RAM.


Oops! That was another difference. Both my setups right now are Rpi4. The first one was a 4Gb and the second one is an 8Gb. I bought the 8gb because the original was locking up already when I started into the second project.

I’m not sure how to troubleshoot the memory. I’ve been watching the memory stats on the client diagnostics and the memory usage stays around 50Mb. When it locks up I can’t get to the stats any longer.