Raspberry Pi

Well i was wandering how many of you out here have got your Rpi and what you think of it.
Is anyone else disappointed? Has any got a client running? what image did you use?
I was hoping the fedora remix or the debian would have a shot? any updates? I received mine and have got
the fedora remix running. no Ignition client yet … Is it even possible since its an arm V6? I had thought that at least
a vision client would run. wont be a very intense one, maybe digital signage…

Still waiting for mine, but my primary thought was for digital signage, like a production/pace counter thing. 1-3 screens that cycle. Non-critical stuff.

I tried the fedora remix, QtonPi, and the debian squeeze.
I have yet to try the ‘wheezy’ but at the moment

I went back to debian squeeze package.
did an apt get update
was able to apt get openjdk 6
for whatever reason the 7 repository didnt work…
also got chromium browser.
I havent tried to get ignition itself on there, but i dont think the pi could handle it
anyway or is likely not compatible but it should…run a client…

from terminal I can ping my machine running ignition service.
it is running…but to no avail I have yet to ‘see’ the gateway homepage.

also i came across a really neat publication that documents the gpio and python.

none the less I am not a linux pro and this is starting to feel like futile effort.
I was hoping to hear some success stories…

Oracle JRE7 and JRE6 only supports headful java on an ARMv7 architecture. The Raspberry Pi is an ARMv6 system, so only headless java is supported.

THe system is not a power house, but once the system boots and is running, it is capable of being used as a intermediate OPC UA server. Ill post back with more soon, just trying to find time to do up a write-up of how to install Ignition on a RPi. I had this working an hour after I got mine…

sounds promising would love to learn from your write up.

whilst awaiting the write up, just some quick questions.

which distro image did you use?
How did you get network browse working?
I tried ‘samba’ but I still could not connect to my gateway.
I did not install ignition, I just want to launch clients.

Has anyone else out here got the Pi running a client?

Greetings all,
Well I have been trying to get Ignition on the RPi with no success while awaiting Kyles write up.
Below are the results of the commands added to the apt resources file.
sudo apt-get update yields the following results:::::

W: Failed to fetch archive.inductiveautomation.com/ … on/Release Unable to find expected entry non-free/binary-armel/Packages in Meta-index file (malformed Release file?)

W: Failed to fetch archive.inductiveautomation.com/ … ta/Release Unable to find expected entry non-free/binary-armel/Packages in Meta-index file (malformed Release file?)

E: Some index files failed to download, they have been ignored, or old ones used instead.

My question would be…What are the correct repository links if there are any?
A quick thought would be is this even possible since it keeps ‘expecting’ armel packages?
My real intentions were to use this as just a client. I did ‘appear’ to get java installed.
Since it gave mention of being ‘headless’ does this mean it will not work as a client?
When I type ‘’ in my browser which is the machine serving Ignition on my windows network
It fails to connect every time…
Is there anyone else out there trying this thing?
I found a different unit that by far out muscles the RPi; its called the ‘cotton candy’.
It looks allot more promising than the gooseberry…
Still anxiously awaiting Kyle Chase’s ‘write-up’…

You cant use the repositories to install ignition on the RPi, you have to install manually from tar.gz. I recommend untarring them to /opt/ignition.

As for my write up, I’ve been absolutely swamped lately, so I have not had time. I am still going to get it done this month.

As previously stated, the RPi has an ARMv6 architecture, so it cant run headful using the Oracle binaries (so no client, only server). I have not tried openjdk, but I presume they would be the same. To get headful java from Oracle, you need an ARMv7 architecture. I have a few of the following boards on order.


Im hoping to get debian/ubuntu running on them, as those operating systems support ARMv7 architectures.


Response appreciated! :prayer:
Please don’t rush the write up on my account.
I am going to switch gears with the Pi and just use it to play around with
Python and other hardware via the GPIO.
It appears fruitless that it will run a graphical client, which is fine. It can have other uses.
The client was what I was wanting to use it for (digital signage). It can do many other things
that I will take advantage of.
Thank you again for the response!

Latest news:

blogs.oracle.com/henrik/entry/o … _for_linux


sounds like something useful lies ahead for the gooseberry!! :thumb_left:

[size=150]From the release notes…[/size]

JDK for Linux on ARM

This release includes support for a new platform, JDK for Linux on ARM. The product offers headful support for ARMv6 and ARMv7.

[color=#FF0000]No support is available for WebStart, Plug-In, Java Flight Recorder, and Garbage First (G1) Collector.[/color] Also some features of the Serviceability Agent are not available for Linux on ARM platform.

So, I’m guessing that lack of WebStart support may be an issue?

It means no launching off the gateway on that machine, but you can launch from a shell script or shortcut still.

Good 'nuff!

Looks like Ill be busy getting that writeup done. I have 1x Raspberry Pi, 2x ODROID-X and our dev board for our boxes. Ill try power through this, and include the shell script to launch the ignition client.

:thumb_left: very cool!

Another one to look at… $49.00 with flash on board…


1G ARM cortex-A8 processor, NEON, VFPv3, 512KB L2 cache
Mali400, OpenGL ES GPU
1GB DDR3 @480MHz
HDMI 1080p Output
100M Ethernet
4GB Nand Flash
2 USB Host, 1 MMC slot, 1 SATA, 1 ir
96 extend pin including i2c, spi, lcd, sensors, …
Running Android, Ubuntu and other Linux distributions

Let the games begin…



I have actually been playing around with the gooseberry this evening. Throwing my share of profanity
at it. I went through oracle’s big ‘survey’ to get to the download for the updated java. I am still in the terminal trying to get installed from tar file. On a disgruntled note, the download STILL SAYS headless for armv6. armv7 was headful… I could be wrong but I still do not believe this will work even with the update. Kyle Chase could chime in with his write up anytime. I am starting to realize I may be expecting too much from these little boards. all I really wanted to do was see ignition run and maybe use for digital signage. so far that has been completely BUNK… I have used it playing around with the gpio so it is not a total loss. for PI owners I think everyone should check out the digital magazine called MagPi. It has some really cool python and ‘C’ tutorials for novice programmers…

I didn’t see the arm version on the wiki for cubie. with some searching we could find out…
It seems to be very important. obviously the most important for oracle java to run.
I have also heard other reports of the ‘ice tea’ working for Ignition (somewhere on here).

Will keep an eye on the cubie…

For anyone with too much time on their hands - There’s a free online pi course.