[Resolved] I still can't download any resourse in exchange,it requires me to login although I have logined in

It seems the problem has happened before ,

I’ve also had similar issues on the download pages. When this happens to me, I’m able to click the user icon to make it recognize that I’m already logged it–give that a try.

I used this method,but it still can’t work

can you download the exchange resource now?

Try logging in from IA’s home page, then opening the exchange.

I tried and failed, you don’t have the problem?

No, works for me. (And I run very tight security in my browser–no 3rd-party cookies.)

Hi @925681905, I’ve had similar issues in the past, but the solution @kirsten.chambers suggested has always worked for me. I also always get the download popup (which can be very frustrating).

I’m predominantly use Chrome, but I might give a few others a test. Could it be a browser type/version issue?

@925681905 Can you try logging in when you are redirected to the global login page? Sometimes you need to log in a second time. Let me know if that works and you are able to download resources.