(SocketTimeoutException:Read Timed out ) after 7.3.1 upgrade

:scratch: (SocketTimeoutException:Read Timed out ) after 7.3.1 upgrade from 7.2.8.

Every time I try to launch the designer from the home page I get this error. This worked perfectly before the upgrade. Is there something new I need to configure? :question:

[edit]Have deleted java cache on both server and client and still get the same symptoms.

Are you using SSL? Make sure port 8088 and 8043 are open on the servers firewall.

I am not using ssl. There is no firewall on either client or server. The antivirus has been uninstalled to trouble shoot and the timeout is still there. When downloading a 200Mb file from this server to the client PC it take about 10 seconds with no errors. Yet ignition times out with this socket timeout error for any ignition files over 800Kb.

I didn’t have this issue with 7.2.28 why am I having this issue with 7.3.1? What can I do to resolve this issue? :/

Let’s try clearing out some caches. Close down all Ignition clients or designers on that machine. First cache is the .ignition folder located in:

C:\Documents and Settings\User.ignition

Delete the .ignition folder. Second is the Java cache. Open the Windows Control Panel and double click on Java. Click Settings from the Temporary Internet Files section of the General tab. Click Delete Files…

Once that is done try launching again.

Latest attempt was on a new machine. Same results. Also cleared java cache and deleted .ignition dir with same results on several other machines where this was all working in 7.2.28… so what next. I really need this to be working.

You should call in to our tech support so we can look into it further with developers.

I will call in the morning. netstat showed these connections:

TCP ServerName:8088 ClientName.perdue.com:1475 FIN_WAIT_2
TCP ServerName:8088 ClientName.perdue.com:1476 TIME_WAIT
TCP ServerName:8088 ClientName.perdue.com:ms-sna-server TIME_WAIT
TCP ServerName:8088 ClientName.perdue.com:ms-sna-base TIME_WAIT
TCP ServerName:8088 ClientName.perdue.com:1479 ESTABLISHED

maybe you can explain what these connections are doing.

I believe I talked with you on either Thursday or Friday when you called into support. I remember we ended the phone conversation thinking that there may have been some anti-virus program that was possibly scanning through all the jar files upon download and doing so at an extremely slow rate. Were you ever able to check into this theory?

As for the TCP connections you posted, I can’t really be certain exactly what they are being used for. Ignition uses several TCP connections at a time to due many different functions. The first connection looks like it is in the FIN_WAIT_2 state meaning that it is waiting for an ACK response from the server so it can then be closed. Three other connections are in the TIME_WAIT state which windows will close automatically after their timeout period, and the last connection is established and actively being used.

All security is disabled for now. We are still seeing this issue.

It seems Java 1.5 is not supported with Ignition 7.3.1… if I load 1.6.x it works. If I load 1.5.11 or 1.5.22 it shows the error in the image below.


What modules do you have installed? OEE?

I just confirmed with an OEE developer… it does not work with Java 5 right now. Work is in progress to change that though.

I uninstalled the OEE and OEE downtime modules, rebooted the server and I still get this error.

We can’t seem to reproduce this here. Do you think you can call into support whenever you get a chance and let them take a look?

When trying to uninstall all of the OEE modules, I only removed those with OEE in the title. A tech at the help desk had me uninstall the Production, Scheduler, and MES user manual also. With all five of the OEE modules removed, we can run without producing the bad .Class file version error.

Thanks for your help.

When you uninstall the OEE module, you have to remove all of the following:
OEE Downtime
Production Simulator
User Manual (MES)

It looks like two separate issues here. The bad version error with Java 1.5 is resolved but the SocketTimeoutException:Read Timed out is still causing problems.

new log…

I have no problem downloading this JAR using my browser pointing to http://MyServer:8088/main/system/jar/msymfact/symbolfactory-designer.jar

but for some unknown reason, your download manager fails every time. Isn’t there some way to see why your application cannot download but my browsers can? Is there maybe a timeout value that can be changed? I have disabled all security on server and client.


new log below... with more info