Submit button on Signature Pad not working only on Windows Tablet

Ignition 8.1.0, Perspective

I am attempting to run a script action on the onSignatureSubmitted event of a Signature Pad.
The script action runs fine on my laptop (Dell Precision 7550).

However, the submit signature button will not work on our windows tablet (Dell Latitude 7212). No events are observed, and there are no errors in console logs. The same happens whether in tablet or desktop mode. I tested with other actions too (logout, for example) with the same outcome.

Both machines running Windows 10. To replicate without too much hassle, I simply made a coordinate container as the root view and added a signature pad. I then added a log out action on the onSignatureSubmittedEvent. On the desktop, the submit button works okay and successfully logs out the user. On the tablet, nothing happens and no error messages are printed. The onSignatureCleared button works fine on both machines.

Any advice or similar issues?

It may be a bug, but you identified your version as 8.1.0. That’s fifteen monthly-ish bugfix releases behind. Have you tried to reproduce with a recent version?

1 Like

I have not… Unfortunately upgrading our Gateway is not within my power at this time.
Deleted last post to elaborate further in the IA requested bug report…

Ignition Perspective 8.1.0
Running on Dell Latitude 7212
Microsoft Edge 42.17134.1.0

1. Expected behavior - The onSignatureSubmitted component event is triggered when either the submit button is pressed or via the .submitSignature() scripting function when using the Signature Pad Perspective component.

2. What happened - The onSignatureSubmitted event is not triggered in either of these cases ONLY when running on the above specified Dell tablet.

3. A list of the steps you took that exposed the issue - Download and import the signature pad demo project. Run this project on a Dell Latitude 7212.

Does it behave this way in all browsers on the Windows Tablet?

We have relatively locked down computers with only Edge and Internet Explorer… Edited the post to include browser information. I can try and petition IT to install Chrome…

It’d be useful to know whether it’s the legacy version of Edge (Blue Icon), or the new Chromium version of Edge

It should be easy to tell the difference based on the icon, but it’d also be good to know the specific version too.

Legacy Edge icon

Chromium Edge icon

if it is Edge that is the problem, I suspect that it’d be the Legacy version.

1 Like

It’s definitely the legacy version.

I read in the documentation - “Event is fired after the Gateway has received a submitted signature”
I am guessing this is security/safety related so that makes sense the browser could be the problem.

I will get IT to update that and respond with any new information.

Thank you both!

1 Like

Updating to Edge Chromium solved the issue!! Thank you both again.

1 Like