Unable to connect to SQL Server 2000

I am having the same issue with version 8.1.1 connecting to a SQL server 2000 database. One thing I noticed is there is not a java.security file in the security folder, just a java file. It contained the referenced configuration ( 3DES_EDE_CBC from the jdk.tls.disabledAlgorithms ) so I am guessing it is the equivalent file. I made the update, restarted Ignition, and still have the same error. Message is:

java.sql.SQLException: Cannot create PoolableConnectionFactory (SQL Server version 8 is not supported by this driver. ClientConnectionId:1358887e-db2a-4609-a912-c59eafbdeed7)

Any other ideas?

I don’t think that any recent SQL Server JDBC drivers support SQL Server 2000.

Microsoft maintains some compatibility matrices here: https://docs.microsoft.com/en-us/sql/connect/jdbc/microsoft-jdbc-driver-for-sql-server-support-matrix?view=sql-server-ver15

I had to use jTDS.

We have a winner, Thank you!!!

1 Like

I had a similar issue with MSSQL v10, Server 2008 R2 going to Ignition v8.1.6 from v7.9.14. Updated the driver to MSSQL JDBC v7.2.2 for jre11 and kept getting the following error:

"The server selected protocol version TLS10 is not accepted by client preferences [TLS13, TLS12]"

The SQL server (which I cannot modify) was apparently requesting TLS1.0 encryption, but the driver refused. Adding the connection parameter “sslProtocol=TLSv1” (and anything else) did not help.

Deleting "TLSv1" and "TLSv1.1" from jdk.tls.disabledAlgorithms in the java.security file appears to fix it.

In Linux, file java.security is located in:

/usr/local/bin/ignition/lib/runtime/jre-nix/conf/security/

2 Likes

This also worked for me

1 Like

Just upgraded from V8.1.3 to V8.1.7 and we lost one of our database connections:
Cannot create PoolableConnectionFactory (The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "The server selected protocol version TLS10 is not accepted by client preferences [TLS13, TLS12]". ClientConnectionId:108f0d77-e759-49c6-af8b-0b6697a9d005)
Going to go back to V8.1.3…

Once the V8.1.7 → V8.1.3 installation was complete the connection became valid again…

8.1.7 deprecates TLS 1.0 and 1.1 due to an upgrade in our bundled Java version, as mentioned in the changelog and the user manual.

2 Likes

See also this topic for a work-around;

1 Like

Rather than downgrading Ignition’s TLS preferences you should prefer upgrading or patching your SQL Server instances: Zulu64 JRE and Database Connection Faults - #2 by Kevin.Herron

No patches for anything older than SQL Server 2008.

:frowning:

Hi guys, this morning I upgraded both master and backup gateway from V8.1.3 to V8.1.7 then on the master, removed TLSv1 and TLSv1.1 from line 729 of the java.security file and restarted the gateway. Master now has a valid connection to the previously connection faulted database. Unfortunately, when I go to the backup gateway, the connection is still faulted. I restarted the backup - no change. I then assumed I needed to edit the same file on the backup and did so then restarted it. It says the gateway is running but I cannot access it and when I go to the master gateway it says the peer is not connected. I reverted back to the old java.security file and restarted and everything is back up as normal except the backup still does not have a valid connection to the previously connection faulted database…

Any chance of a typo when editing the backup’s java.security file? Maybe copy the working one from the master to the backup?

2 Likes

I was thinking the same thing and had a look at each file and they look identical. Thought I would post to the forum just incase it could be something else I was missing. Ok, will try copying over the master’s file and restarting.

That did the trick, thanks @pturmel!

2 Likes